Fibaro FGD211 and Flickering LED

Hi All,

Before installing the FGD211 units throughout my house the electrician has made a test rig to check that the dimmable LEDs we are installing will work correctly. Everything works fine and the LED lights dim from 0% - 100% (and turn completely off when at 0%). However, when the LED light is in the range of 60% - 90% the light flickers (not strobing, but the brightness flickers enough to be annoying and noticeable). This stops when the light reaches to 100% (and the FGD211 also stops buzzing, presumably indicating it is no longer dimming which stops the flickering too).

There also seems to be no brightness difference between 60% - 100%. I have set the maximum brightness of the FGD211 to be 60 but that just stops the dimmer when it reaches that level - it still flickers as I assume that the dimmer is still trying to dim the light to that level (as it is buzzing) rather than just setting it to 100% of what the light can handle.

Any help on how to fix this problem would be appreciated. There is currently no bypass unit installed in the circuit.

The light is a PierLUX ECO LED (ECOLED1/10/3K), 12W LED and 14W total system: .


Do you have a neutral connected to your FGD211 or is is running in two-wire mode?

I have found that the Fibaro bypass module is very helpful when dimming low-current loads.

As Rex mentioned, using the bypass will usually correct the flickering.

You don’t say what the bulb power is, but it sounds like you are using a single LED, so I would expect the load to be less than 25W - which is the minimum load for the Fibaro Dimmer.

Also you will get different results without the bypass if you are using 2-wire (no neutral) or 3-wire system.

Take a look at our guide about using the Dimmers with LEDs -

Also, we recently did some testing with the dimmers and a few Megaman LEDs. You’ll see that you get different results with different LEDs, so there is no single way to get this to work, but starting with the bypass will be the best place to start.

Hope that helps.

Best Regards,
Mark Onions - Vesternet

Thanks for your help Rex and Mark. I’ll get my sparkie to hook in the bypass unit and see whether that resolves the problem. I am using a 3-wire (neutral) system.

Mark, I read your excellent Vesternet guide on dimmable LEDs. The guide with my Fibaro dimmer does not mention configuration parameter 20 at all - I am a bit hesitant to change that, as I don’t know the original value (to reset it back to, in case things go badly). Can you advise on this aspect?


Sorry, my mistake! I have now seen that parameter 20 is mentioned under the “Advanced Function” section :slight_smile: I notice that there’s a different default setting depending on the Hz. How can I tell if my setup is 50Hz or 60Hz (in case modifying this setting does not improve things, or makes it worse, and I want to revert it back to its original setting)?

Setup configuration parameter 20 as Monitor Only and note the current value before you change it.

Thanks Rex. Configured parameter 20 and I now have flicker-free lights! However, the buzz from the FGD211 seems to be a bit louder now - is that normal, and will it go away once the unit has been “run-in” (for lack of a better term)?