FIBARO FGBS-222 Smart implant integration

Anything new about Smart implant and temp sensors?
I am New in vera and lua code So please be tolerant.
I’ll found something like this: http://forum.lic.pl/vera/vera-urzadzenia-zewnetrzne-(ethernetowe)/
"

<?xml version="1.0"?>
local TEMP_SERVICEID = "urn:upnp-org:serviceId:TemperatureSensor1"

function poll()
  local code = luup.variable_get(TEMP_SERVICEID, "Code", lul_device)
   if code ~= '' then
    local len  = string.len(code)
    local status, result = luup.inet.wget("http://admin:admin@192.168.1.100/st0.xml", 5)
    if status == 0 then
       local x = string.find(result,code)
       local y = string.find(result,'/'..code)
       result = string.sub(result,x+len+1,y-2)
          result = tonumber(result)         
          if result ~=-600  then       
             result = result / 10
            luup.variable_set(TEMP_SERVICEID, "CurrentTemperature", result , lul_device)
           luup.variable_set(TEMP_SERVICEID, "LastUpdate", os.time(os.date('*t')), lul_device)
       end      
  end    
 end    
  luup.call_timer("poll", 1, "60", "")
end


function startup()
  local code = luup.variable_get(TEMP_SERVICEID, "Code", lul_device)
   if (code == nil) then
      luup.variable_set(TEMP_SERVICEID, "Code", "ia7", lul_device)
  end

  local CurrentTemp =  luup.variable_get(TEMP_SERVICEID, "CurrentTemperature", lul_device)
 if (CurrentTemp == nil) then
      luup.variable_set(TEMP_SERVICEID, "CurrentTemperature","33" , lul_device)
  end    
 poll()

end

startup

"
But it does’t work.
Maybe you can fix it.
Maybe this will help you finished your mission.

As far as I can understand the google translation, this seems to be for another controller, sending its value from ethernet. I’m sorry but we have to wait for them to implement this, since I cannot find a way to route the value from the 8th channel to its child device, no matter what I tried. Internal temp seems to be OK, but it’s useless.

Try to include Smart Implant using the wizard for Fibaro FGS-223.

Does this make the external Temperature sensor reporting ok? That’s the only part I still need to fix. I’ll try with a spare unit over the weekend.

Yes, this should solve the multilevel sensor report for endpoints e8-e13.

1 Like

I will try and report back. Thanks!

My first Post :slight_smile:

I bought one of these as a replacement for the FGBS-001 Universal Sensor and started out with all the above problems.

Tried the pairing (as desribed above) as a FGS-223 and hey presto all of my (4) Temperature sensors started reporting!

Brilliant, thanks for the post! :slight_smile:

2 Likes

Please describe solution of pairing device, because I also try do this and always is added the same device (generic IO x2, appliance module x2, GET_LANG x5). I also have 4temp sensors.

Make sure the device is Unpaired (select Delete from Vera and triple click the device, should give you a Red light, shortly on the device).

Run the pair proces from a PC (it does not work from the Mobile App, for some reason?!)

Follow the on-screen guide, exactly and be patient after triple clicking - it will take some time.

-oh and goes without saying: you select the FGS-223 under “Dimmers and lights” as your device Type! If I select the “Generic z-wave device” I also have this Problem.

This will make the temp reporting work again - I can confirm this. I had to run my script anyway, since digital inputs are still mapped in the wrong way, but at least the device is now fully usable. thanks to @mcv.bogdanf for the tip!

1 Like

Guys I really need your help. I am doing exactly as you describe, by adding fgb-223from wizard using pc, and i can See only one difference the external temp sensor does’t report. The Rest unchanged ( generic IO x2, appliance module x2, GET_LANG x 4). What am i doing wrong?

  1. Login on home.getvera.com
  2. Connect with my vera controller (vera g100) software version 1.7.1040
  3. Clicking Devices menu
  4. Add device
  5. Search and click fgs-223
  6. Next-next until i See countdown. Then triple clicking fgbs 222
  7. Fgbs-222 green Led is on, and timer still countdown until it reaches 0
  8. Next is Page with name of device
    And that’s it (generic IO x2, appliance module x2, GET_LANG x 4, temp sensor x 1 but does’t report, and named device)
    Please help

I’m on FW 7.30, and I’m experiencing problems with pairing, maybe related to this, maybe related to this FW.

Anyway, I can only map temp sensors (binary sensore are not working) and I found that it’s impossible for me to set device parameters (it’s stuck on “Getting secure classes”).

I’ll probably go back to a previous backup later tomorrow. Unfortunately this device is not properly supported, even if it’s not very new to the market.

So, I was finally able to get it working 100% (at least binary inputs + temp sensors).

Just pair as generic, because if pairing as FGS 223, temp sensors will work, but binary sensors will not.

Then, run the updated scripts in the other thread, to fix missing variables and configuration. Just issue a luup.reload() and you’ll be done. Device will be paired secure and inputs will work.

@mcv.bogdanf I found that temperature reports are not working, unless I manually poll the device. Is there anything special I can configure to avoid a scene running a polling every now and then? Thanks.

Hey all,
First post from me guys, so bear with me. I have one of these fgs-222 devices and am trying to add 4 external temp sensors (DS18B20)

I have tried adding as fgs-223, and see some external temp sensors among other devices as discussed above. Getting the ext sensors to check for temp every 60 secs is my issue.
I also tried deleting, then pairing as generic, as ‘therealdb’ suggested, where I don’t see the ext devices as temp but instead as generic, due to the xml they are using.

My question is, following that other thread, I tried to add a new implementation xml file (pasted from the code and edited my IP) under Apps -> Develop Apps -> Luup files… Then I created a new device using the implementation file I created and D_TemperaruteSensor1 as the xml file (which was referred to in the implementation file). I get a new device displayed. What do I do now? How do I associate that with the generic master device created earlier? OR how do I get the external devices to use this? Do I add the parent ID for the new device into all the ext sensors?
I’ve also tried the luup reload (http://:3480/data_request?id=reload.

Cheers,
Tim

no need to change the implementation file. the script should be run one time only. I adapted it to use 4 endpoints, if you need more, just change to code. My sensors are reporting OK and everything is working as it should.

Great thanks. Makes more sense now.

Hello, is there anyone who knows when this device will be introduced in Vera database in order to add simple and correctly inmediately?
I soupose Vera team reads this threads, this Smart Implant FGBS-222 it is already selling buy fibaro long time ago, sin april!!!
happy new year

Hi,
is the module fully recognized (v5.1) ?
are the outputs controllable separately from the inputs ?

Hi there. Am running 7.4x here and am trying to use the FGBS-222 to sense an open or close on a dry contact. I’ve joined it using the ‘generic’ z-wave device. Where is the script that you are referring to ? I can’t seem to find another thread where it is. Thanks
-bh

it’s in the 3rd post of this thread:

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules