FIBARO FGBS-222 Smart implant integration

Are there plans for VERA integration in the future?

Hello @BerrytH,

When it comes to FIBARO FGBS-222 Smart Implant there is no information about official support or integration in near future.

You can check whether the FIBARO device works with specific hub here:

If you have Vera controller and you want to add FIBARO devices to it you can use following link:

Best regards,

I could do with this device being added to Vera also.

I would also be interested in having this device supported

This looks like a pretty phenomenal device. I picked one up and connected as a generic device to VERA. Vera picks up the IO and the temp sensor so I am going to play with it. Vera integration would be excellent as this is quite a powerful little device and super super small. C’mon eZLO guys !!!

I ordered two Universal Binary Sensors, but the shop sent me two Smart Implants (at a very low price, so I’m not complaining too much). I confirm it’s not working at all. It adds about 8 child devices, but they seems to not report their value correctly. I’ll try to hack something, and I’ll report if it’s usable.

I was able to get it working with binary inputs. More info here:

Thanks for your work. I could follow for Input 1+2 and it works.
But I need realy DS18B20 to work, please don´t stop trying!

I’m still trying, since I need it too. I’ll update my post in case I’ll found the solution.

Anything new on your smart implant mission @therealdb ?

I tried everything but unfortunately I wasn’t able to make the 8th channel report back. I can see it but it’s not reporting. I’ve asked the dev team for support and they said they have not this device in their lab so we should wait at least next fw (7.31).

Anything new about Smart implant and temp sensors?
I am New in vera and lua code So please be tolerant.
I’ll found something like this:

<?xml version="1.0"?>
local TEMP_SERVICEID = "urn:upnp-org:serviceId:TemperatureSensor1"

function poll()
  local code = luup.variable_get(TEMP_SERVICEID, "Code", lul_device)
   if code ~= '' then
    local len  = string.len(code)
    local status, result = luup.inet.wget("http://admin:admin@", 5)
    if status == 0 then
       local x = string.find(result,code)
       local y = string.find(result,'/'..code)
       result = string.sub(result,x+len+1,y-2)
          result = tonumber(result)         
          if result ~=-600  then       
             result = result / 10
            luup.variable_set(TEMP_SERVICEID, "CurrentTemperature", result , lul_device)
           luup.variable_set(TEMP_SERVICEID, "LastUpdate", os.time('*t')), lul_device)
  luup.call_timer("poll", 1, "60", "")

function startup()
  local code = luup.variable_get(TEMP_SERVICEID, "Code", lul_device)
   if (code == nil) then
      luup.variable_set(TEMP_SERVICEID, "Code", "ia7", lul_device)

  local CurrentTemp =  luup.variable_get(TEMP_SERVICEID, "CurrentTemperature", lul_device)
 if (CurrentTemp == nil) then
      luup.variable_set(TEMP_SERVICEID, "CurrentTemperature","33" , lul_device)



But it does’t work.
Maybe you can fix it.
Maybe this will help you finished your mission.

As far as I can understand the google translation, this seems to be for another controller, sending its value from ethernet. I’m sorry but we have to wait for them to implement this, since I cannot find a way to route the value from the 8th channel to its child device, no matter what I tried. Internal temp seems to be OK, but it’s useless.

Try to include Smart Implant using the wizard for Fibaro FGS-223.

Does this make the external Temperature sensor reporting ok? That’s the only part I still need to fix. I’ll try with a spare unit over the weekend.

Yes, this should solve the multilevel sensor report for endpoints e8-e13.

1 Like

I will try and report back. Thanks!

My first Post :slight_smile:

I bought one of these as a replacement for the FGBS-001 Universal Sensor and started out with all the above problems.

Tried the pairing (as desribed above) as a FGS-223 and hey presto all of my (4) Temperature sensors started reporting!

Brilliant, thanks for the post! :slight_smile:


Please describe solution of pairing device, because I also try do this and always is added the same device (generic IO x2, appliance module x2, GET_LANG x5). I also have 4temp sensors.

Make sure the device is Unpaired (select Delete from Vera and triple click the device, should give you a Red light, shortly on the device).

Run the pair proces from a PC (it does not work from the Mobile App, for some reason?!)

Follow the on-screen guide, exactly and be patient after triple clicking - it will take some time.

-oh and goes without saying: you select the FGS-223 under “Dimmers and lights” as your device Type! If I select the “Generic z-wave device” I also have this Problem.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules