Fibaro Dimmer 2 remember last brightness at switching on

I just started to use a VeraEdge as a HUB of Home Assistant.
The reasons for that is that a Zwave USB straight to HA didn’t give a reliable usage as I wished.
Now with Vera I do have a more reliable zwave network, so I’m happy.

I just paired a Fibaro Dimmer 2.
It is working fine.
Except that de dimmer paired straight to HA was remembering its last brightness at switching on.
Now at switching on, the dimmer is going to 100% brightness.
How to switch it on with remembering the last brighness value?
Thanks for the answers

How are you switching it on?

I just switch it on in HA without the brighness option.
If I did that when the dimmer was paired straight to HA it was remebering the last brightness

Do I need to change one of the variable at the dimmer in Vera?
(the LoadLevelLast is 100 for example)
Can I change that value?

It is possible to change vars in the dimmer by a number.
How do I set these in VeraEdge?

Device > Device Options

There’s a button for ‘Add Configuration settings’
That’ll create boxes for you to fill in your desired values.
Hit save
Wait for the Luup reload
Your device will need to wake up to take the new setting


Thanks for your advice.
I try to set group 0, setting 19 (force brightness at switch on) doing this (with no effect):

What am I doing wrong?
Do I need to put “0” into group ID first?
(because variable 19 is part of group 0)
as far as I know the dimmer is always awake

According to the manual you posted, the value must be between 0 and 99. You appear to have a ‘$’ symbol there.


Then I think you’ll also need to set variable 21 to 1

Then I think you need to set the association which I think is the ‘Add group’ button below. Not 100% sure on that though.


Thanks again.
Its not a $ but a 5.

Funny you mentioned set variable 21 to 1.
Because 0 says remember the last setting, and thats just not happening while I like to achieve that

Sorry, shonky work monitor

So are we reading the same manual? I can see from your image posted there:
Variable 19 > is active > Always sets this brigthness level.
So you have that set to 5 which means when you single click S1 your light should come up to 5% brightness from an ‘off’ state.
Is that happening?
Have you pressed ‘Save change’?
Was there a Luup Reload
Have you done a browser reset.

Variable 21:
Default is 0 which sets any associated devices to their last saved state. Not the state of this device that we’re working on.

I assume this will be their last ‘on’ brightness but I could be wrong. My apologies I assumed that you wanted them all to come up to the same brightness. Setting Variable 21 to 1 will do that.

So let’s focus on 19…


I think there is an error in the interface somewhere between Vera and Home Assistant.
If I switch in Vera app the switch does remember the last value and switching to that brightness.
If I use the fysical switch at the wall also it remember the last brightness.
If I switch in HA or by hand at the overview page (thats the way I tested it) or by a flow it is going to 100% brightness.
So it looks like nothing wrong with Vera itself and its settings, but between Vera and HA