Failed UI3 upgrade - now I can't Factory Reset

The upgrade (saving settings) appeared to hang. Left it for over an hour and it never reported it was done. So I tried refreshing the browser with no luck. FindVera says there is a communications error. I can’t reach it at or at

Meanwhile at the box, the power light is flashing slowly. I’ve tried lots of combinations and speeds of button pushes and unplugging it overnight and the power light just keeps slowly blinking.

Vera had been functioning as a switch behind my main home router. I’ve made no other changes to the network and I have an Internet connection.

I did save a backup before the upgrade. Any way to restore either to that or factory state?

Unfortunately, when the power light is flashing slowly, that means the firmware got corrupted. Normally this happens only if you unplug Vera while it’s in the middle of flashing the firmware. Although we have had very rare reports of customers saying it happened without this, as it seems to happened to you. The problem has nothing to do with UI3, btw. It’s a hardware issue where the flash image wasn’t written properly. There are 2 ways to solve it. One is you can use the recovery utility here: to flash any firmware onto the Vera. You can simply use the UI3 firmware link instead of the one shown if you want to use UI3 instead. If you started an upgrade with preserve settings, your settings will still be preserved after you finish. The other option is to contact us for an RMA number and we’ll exchange it or flash it for you. Sorry for the inconvenience.

Click the black button twice on vera very quickly.

The recovery utility did it! I didn’t know there was such a thing. I’m very glad I (we) didn’t have to bother with an RMA.

I got so confident I tried the upgrade to UI3 again and this time it worked in just a few minutes. Maybe I got a bad download last time?

Anyway, thanks!