Failed to open IO port

Moved from Vera3 to VeraPlus and upgraded to UI7 at the same time. I left the Vera3 on and plugged into the AD2USB, but tried switching it over to the Plus yesterday and doesn’t seem to be working. Any suggestions would be appreciated!

Did you go into the serial port settings and associate the USB port with the alarm plug-in?

Sigh. No, no I did not. That cleared things right up! Thanks for the reminder!

OK, I’m just getting back to trying to get this working after many months. I thought changing the serial port settings had worked, but no luck…

I’ve gone back and forth with vera support for weeks and they finally had me uninstall and reinstall the app, so of course lost all of my settings and door/windows at the same time.

I’ve gone back through and updated the serial port settings and keypad addresses, but I’m getting an error which says it failed to open i/o port and can’t detect device. If there are UI7 specific installation instructions, let me know–I haven’t been able to find them. This i/o port issue is the same problem I’ve been having since the transition.

Any suggestions would be very appreciated. This one is driving me nuts…

For anyone else dealing with this issue, I think I’ve got it figured out. When I configured the serial port, two serial ports were showing up, likely as a legacy from the vera3. Both ports needed to be addressed to vera partition and have speed set in order for the plugin to be functional. Amazing that tech support didn’t catch this after going back and forth for 2 weeks…

Wilme2 said to associate the serial port to the USB port, or something like that. How do I do that? I am having the same problem as the author of this older posting.

In UI5 it is under Apps/Develop Apps/Serial Port Configuration. You associate the port to the device…

I am so under-qualified to work with this thing!!!

  1. I’ve tried to figure out what version U15, U17, U??? I have running. I am running firmware version 1.7.3015, but have no idea what that has to do with U??.

  2. I found the screen you referred me to. There are two devices showing:
    Name usbserial ftdi_sio
    Device No. usb-rt3883-0hci-1 usb-rt3883-ochi-1
    IP address
    Port 3481 3482
    Baud 115200 115200
    Parity None None
    Data bits 8 8
    Stop bits 1 1
    Used by device “Please select” Vista-20P [Security]

Again, my message at the top of the Devices screen is “Vista-20P[33] : Failed to open IO Port”. I don’t have any clue how to interpret what I listed above to know if it is right or wrong.

If you have any guidance for someone that is a total novice, I’ll look forward to it. Thanks SO MUCH!!

[quote=“k7jv, post:8, topic:191916”]I am so under-qualified to work with this thing!!!

  1. I’ve tried to figure out what version U15, U17, U??? I have running. I am running firmware version 1.7.3015, but have no idea what that has to do with U??.[/quote]

I feel your pain - I also very feel very underqualified many times trying to solve problems. But I do know that the 7 in 1.7.3015 means you are using User Interface (UI) 7. It helps the masters know how to help.

Note how I place a lot of this information in my signature page.

Thank you, Don. I was thinking U15 and U17, and as you pointed out it should be UI5 and UI7. Someday I may get some of this figured out. :blush: Cheers and thank you again.


I see 1 probable and additional possible issue with your configuration.

First, the entry you should be configuring for use is the second one with the name ftdi_sio. The other one to my knowledge won’t do anything.

First fix:

  1. Change the port of the ‘usbserial’ device to something other than 3481 (perhaps 3483 or something).
  2. Change the port of the ‘ftdi_sio’ device to 3481.

Second fix:
Ensure that the “Used by device” of the ‘ftdi_sio’ entry is set to the panel device and not the keypad device that the plugin created on Vera. You can tell the difference when you look at the devices in the Vera. The panel device has a single button on it that says “clear”. This is the one to specify in the “Used by device” field. The keypad device has the “Away”,“Stay”,etc buttons. This one should NOT be specified in this field.

To make it easy, you may want to rename both of those devices to ensure that you can easily tell the difference when selecting it on the serial port entry.

I hope this helps.

U15 and U17 - I think soccer.