Factory Reset on Vera 2

Brand new device, cant seem to connect to the management console after reboot.

I also am finding backups from several months ago on the server, but I just recieved it two days ago. Maybe this was a return that was sold as new?

Either way, I need to find out how to reset this back to factory. the button press solution from the V1 wiki doesnt work


I opened a support case and have still not heard back from MiCasaVerde, after calling their support line I was eventually dumped into a voicemail prompt and then hung up on.

The Vera 2 has an eth 1 light double blinking, which means no internet. unfortunately it is not grabbing an IP from DHCP and none of the default ip’s listed are working either. I need to find a way to factory state this device.

can anyone offer some assistance on this? I am getting the feeling that this is a Refund waiting to happen.

To do a factory reset, you need to tap the reset button twice quickly. After a few seconds, you’ll see all of Vera 2’s LEDs go out while it goes through it’s reboot routine.

I have done this a number of times with no luck in returning to factory state. using a pick, I have double pressed the reset switch as quickly as I can. maybe .20 or .25 of a sec between presses.

In every case, and even when the reboot occurs the power light is constant with no change in state.

At this point, my eth0 light is double flashing and regardless of network connectivity no usable IP is available for connection.

Question, does the factory restore overwrite all configuration or does this just deal with MCV settings?

Also, can a restore image be attached via USB Flash Drive and triggered for restore?

When I got home, I followed the instructions provided here in the forum and the following occurred

  1. two distinct presses of the reset button with a small pointed instrument.
  2. eth0 stopped blinking and was steady on for a moment.
  3. device appears to reboot twice (USB 1 light comes on as it does during normal boot two times)
  4. same behavior, eth1 flashing in double flash pattern.

Note: when inserting a working Ethernet cable into eth2, the eth2 light does not come on or flash.

I have tried a variety of speeds for pressing the reset button twice, with either the same result or no reboot at all. Odd, it is a reset button…

Any other suggestions would be appreciated.

Looking into the MCV Mantis Database, it seems this issue was reported to be a bug in January…


The sercomm units are the new style Vera hardware with the 3 buttons. Model Number NA401 specifically is what I have in hand.

Guess I will be looking for an RMA as the reset method is not an option for me. In any case, I hope this saves someone else a week of torment.

BTW, still have not recieved a call back from MCV Support. It’s been about a week at this point…

Seems to be a common occurrence lately where Support is AWOL…

Shame really cos it doesn’t take too many occurrences of this to cause negativity and bad reputations to spread along with missed sales opportunities from people recommending the product!

There is a lot of work going on with UI4 so I guess they are busy trying to get that out of the door and missing posts like this.


Please answer to my email so we can schedule a phone meeting and solve this.


Was this ever fixed?

Is there any way to reset Vera2 to a factory defaults w/o working Web UI? The buttons on the Vera2 box don’t seem work!

Try this command:

/usr/bin/cmh_Reset.sh all