EzloPi WiFi fails to configure

I am setting up a brand new installation of EzloPi firmware on an ESP32 development board following the procedure in the EzloPi User Manual. All goes well until I get the step of WiFi configuration, where I get the error message “WiFi connection failed”. I have checked and rechecked that the SSID and password are correct, and have tried with two WiFi networks that I have in my home, and still get the WiFi connection failed error. What else should I look at or check to try to get past this error? My ESP32 controller shows on my dashboards (Desktop Configurator, mios mobile, and Vera dashboard) as “controller offline”, which is not surprising as I cannot set up the WiFi network connection. Any help would be appreciated. The log shows : “Json Data: {“cmd”:2,“status_write”:0,“status_connect”:0}”

There may be some illegal characters in the SSID or more likely the password? Illegal to EzloPi I mean.

Can you temporarily swap password to simple text only characters to see if that fixes it??

Hi @Warren_Willis
The WiFi module on the ESP32 consumes a lot of power, for example you can run a non-WiFi FW without any problems, but when you trying to connect WiFi module to access point the device reboots because it’s not getting enough power. Poor quality USB cables are usually the issue for these cases, but swapping to a different USB port on your computer may also help.
The simplest way to power the board it to plug it into a good 5v USB charger with a good quality cable. You won’t be able to see the serial output this way, but if the device shows as being online in then you’ve proved it was a power issue.

Write please if you still have this issue after replacing the power and we will continue search for the root cause.

Firstly, the passwords use only lower case letters and numerals, so there should be no problem with those. Secondly, powering the ESP32 directly from a 5v, 2A plug pack did not help, probably because the WiFi connection has not been configured. Is it possible that the fact that I am in New Zealand could be a snag?

Looking through the debug log I spotted this::10.02.2024 13:38:43: 3): Disconnect reason[15]: WIFI_
10.02.2024 13:38:43: REASON_4WAY_HANDSHAKE_TIMEOUTe[0
What does this mean?
Here is the debug log when I attempt to configure WiFi following a restart:
10.02.2024 13:58:25: [0;32mI (41523) ./services/qt_s

10.02.2024 13:58:25: erial/qt_serial.c: (144): {“cmd”

10.02.2024 13:58:25: :2,“pass”:“h***************”,"ssi

10.02.2024 13:58:25: d":“**********”}[0m


10.02.2024 13:58:25: re/ezlopi_wifi/ezlopi_wifi.c (24

10.02.2024 13:58:25: 0): SSID: *********, Password: *

10.02.2024 13:58:25: **************

I (41523) wi

10.02.2024 13:58:25: fi:flush txq

I (41523) wifi:sto

10.02.2024 13:58:25: p sw txq

I (41533) wifi:lmac stop hw txq

10.02.2024 13:58:25: I (41563) wifi:mode : sta (d4:8a

10.02.2024 13:58:25: :fc:a0:bf:1c)

I (41563) wifi:en

10.02.2024 13:58:25: able tsf

[0;33mW (41563) ./ezl

10.02.2024 13:58:25: opi-core/ezlopi_wifi/ezlopi_wifi

10.02.2024 13:58:25: .c: (112): 'tcpip_adapter_set_ho

10.02.2024 13:58:25: stname’ ERROR: ESP_OK[0m


10.02.2024 13:58:25: 3mW (41563) BT_LOG: esp_ble_gatt

10.02.2024 13:58:25: s_send_indicate, The connection

10.02.2024 13:58:25: not created.[0m

[0;31mE (4156

10.02.2024 13:58:25: 3) ./services/qt_serial/qt_seria

10.02.2024 13:58:25: l.c: (220): wifi_error: 0[0m

10.02.2024 13:58:25: [0;33mW (41583) BT_LOG: esp_ble_

10.02.2024 13:58:25: gatts_send_indicate, The connect

10.02.2024 13:58:25: ion not created.[0m

[0;33mW (

10.02.2024 13:58:25: 41593) BT_LOG: esp_ble_gatts_sen

10.02.2024 13:58:25: d_indicate, The connection not c

10.02.2024 13:58:25: reated.[0m

[0;33mW (41593) BT

10.02.2024 13:58:25: _LOG: esp_ble_gatts_send_indicate, The connection not created.[

10.02.2024 13:58:25: 0m

Hi @Warren_Willis
This is the rare type of problem with WiFi connection.
I am working on firmware and for tracking the problem cause, could you share some more logs ?
In the meantime I have few questions.

  1. Is you WiFi is in 2.4GHz Wireless band ?
  2. Is your EzloPi device is within the range of the WiFi signal.
  3. Was your board working fine with WiFi if in any case you had tried some other WiFi applications ?

Tomorrow, if I can manage the time, I will delete everything and make a clean start with new installs, and post the logs. In answer to your questions:

  1. Yes, definitely 2.4GHz - my router is a Netgear R7000P which provides excellent signal coverage throughout the house. I had also tried connecting to my Vera Plus at 2.4GHz with the same failure result.
  2. Yes, it is currently just two rooms away, within a timber framed house.
  3. The board is NOOB, so this is the first time I have used it. It is a ESP32-WROOM-32D with a CP2102 UART. It appears to power happily from the PC USB. I have assumed this to be a “Generic ESP32” for the purposes of EzLogic EzloPi.
    Also, router encryption is set as WPA2-PSK (AES). Is this what is expected?

After searching support websites for ESP32 problems I found one with similar error who solved the problem by rebooting his AP. After rebooting my router I found that I was able to set the WiFi credentials, and the EzloPi Configurator log showed: Json Data: {“cmd”:2,“status_write”:1,“status_connect”:1}. I still have no idea what was causing the original problem.

I reflashed the board but now have the problem that I have three devices registered, 102001137, 102001141 and 102001142. EzloPi sees the device as …137 but the Mios App sees it as …142, and the router shows it as …137? My Vera dashboard shows only …142 (I had deleted the other controller numbers there previously). How can I clear the redundant registrations and have everything aligned as …142?

After reinstalling the software, configuring the board and flashing the firmware as …142, and then deleting and reinstalling the Mios App, I now have the correct device appearing on my Mios App dashboard. Also the router sees device …142 as the connected device. All good so far. However, the controller still shows as Offline on the Vera dashboard, and I still have the old redundant device numbers showing on the drop-down of Registered Devices on the EzloPi Configurator. How can I fix these issues?

Hi @Warren_Willis
One of the device did not properly work maintaining WiFi protocol thus having problem in handshake, and it seems that it is more likely to be an AP problem. Answer to your question, WPA2-PAK (AES) encryption is fine.

Those redundant devices were created while you flashed several times before you fixed the WiFi problem. Thus the previous devices 102001137, and 141 was overwritten with 142 data. Now to get rid of these redundant controllers you can go to MiOS dashboard or MiOS app and delete them.

On MiOS app: Go to More->My Controllers->Select the controller you want to delete with “>” arrow → Delete the controller from there.

On MiOS Web Dashboard : Go to Settings → Controllers → Functions → Maintain / Remove
Feel free asking any further queries.

Thank you for using EzloPi.

The Vera dashboard works with Vera hubs only, whereas the Ezlogic is the Web UI that offers extended functionality (including advanced scene engine - Meshbots) for Ezlo hubs and EzloPi devices. You can log in to ezlogic.mios.com and explore all the capabilities that we have for Ezlo hubs and EzloPi devices.
This week we are making changes to the Vera portal to avoid seeing Ezlo hubs as being offline on the portal.

Thanks @Max, That deals with the Vera portal. Presumably the EzloPi device will disappear in due course. However, my question remains regarding the old redundant device IDs still appearing in the drop-down of Registered Devices on the EzloPi Configurator. These redundant devices do not appear in the Mios App or in the web dashboard, only in the configurator. Having them remain there is confusing - i.e. are they valid registered devices or not?