Ezlo Plus include/exclude mode failure

My main Ezlo Plus is slowly being populated with devices that I’m removing from my Vera Secure. As I add more and more devices using the Android app the include/exclude process now has a 95% failure rate. It took me 6 hours to add 3 devices yesterday. It seems to be directly associated with the amount of devices on the controller. This is not a new problem as I had a ticket with support about 10 months back and they acknowledged the problem at that time but nothing was done about it. There has been many firmware and Android app updates since but not fixed yet.

I have 3 Ezlo Plus units:
Unit 1: My test unit, rarely has more than 2 devices at one time. Include/exclude works fine.
Unit 2: Rental cabin with about 21 devices. 50% chance of getting the include/exclude to work.
Unit 3: Main unit with about 52+ devices 5% chance of getting the include/exclude to work.

Using the Android app on my main unit I select my device to add and start the include process. The 60 second count down starts but the LED stays blue through the 60 seconds. I select the exclude option and the same thing. I can do this over and over with the same results. Restarting the app has no effect.
If I’m really lucky sometimes switching from include to exclude mode the LED start blinking. I can switch back to include and some times it works as well. Not very often though.

Its getting to the point that I hate the thought of adding devices as I know I’m in for hours of frustration.
Anyone else experiencing this on Ezlo Plus that has many devices? I’m still wondering why after reporting this issue and getting confirmation there was a problem there is still no fix. :weary:

Edit: I’m also noticing that many devices have become non responsive or very slow to respond to a state change.

What was your ticket number?

I’ve not seen this issue but I have less than 10 devices paired to my Ezlo Plus.

Hello @JimMac
Customer support will contact you to get more details on the issue you reported. Having those details (logs) we can investigate this issue on our side. Sorry for the inconvenience that you faced using Ezlo Plus.

It was ticket 246287 dated 2021-03-31 with the description “Ezlo Plus include/exclude not working”. Support person was Brenda Rojas. As part of that ticket and trouble shooting I sent a video of the same issue I’m having today. This was one of the reason back then why I put all my devices back on my old Vera Secure. Brenda said she shared my logs with the developers last March 2021.

Today after a few more hours of trying to get the Ezlo Plus into include mode I had 100% failure rate over 10 attempts. Through more testing I decided to leave the Android app in include mode even though the 60 second timer reached 00 and after a few minutes it did enter include mode. Unfortunately the app no longer had control over the process and no devices were detectable and there was no way to exit the include process. The Ezlo plus was now in an endless loop of unusable include mode, killing the power was the only way to stop it.
Maybe this is a timing issue? I set my hub to debug logging and still waiting for support to contact me.
End result, a hub that can no longer add or remove devices so I have been using my Vera Plus to exclude the next few switches I want to migrate over.

I’ve been trying to pair some Centralite ZIgbee devices today on my Ezlo Plus.

Initially I couldn’t get any of the devices to pair at all and was seeing Inclusion Failed Messages.

I then later pulled the power lead out of the Ezlo Plus and back in again and after that things started working and I was able to pair all the devices.

Also you must wait when is says Pairing Device please wait, even if that 60 second count down has finished, just keep waiting which is what I did and then eventually the device was added and the app moved on to the final step. where you can rename the device and also assign it into a room etc.

I never get to the “device detected” part. Wish it did. The LED never flashes indicating the pairing mode has started until long after the counter stops and by then its too late, it won’t detect anything.

Hello Jim,

We’ll investigate the problem once more and follow up in a support ticket you previously had created as we need to gather some logs.

Most of yesterdays activities and all of today’s should have been captured in debugging level logs and is just waiting for support to access.

How do I track the progress on this ticket?

Hi there Jim,

Could you please try to exclude and include devices on the busiest controller you have and let us know when you do it?

Have you made any changes to my controller? I notice that over the last few days my hub was flashing yellow a few times and after a few hours I had to power cycled it. The reason I’m asking is I already sent you that information. If you made changes then I’ll do it again.

Haven’t heard anything lately. Were you able to get the logs, find the issue? I’m still not able to add anything. Starting to move my devices back to my Vera once again.

Hello Jim,

No, we did not make any changes in the past few days, however, today I just pushed another update to the controller, please check if the controller is now behaving correctly.

That update helped some. Inclusion mode worked most of the time but not always. I installed 3 devices.
Zooz Zen21 switch - After 3 attempts it installed correctly. First 2 failed S2 encryption and stopped at 5%. Third attempt worked with S2 encryption.
Zooz Zen21 switch - Installed without S2 encryption. Did not give me a choice. I left it like this for now.
Zooz Zen20 power bar - Installed. During the install the % progress indicator jumped all over the place.

Could not get exclude to work at all. Used another Ezlo Plus to do all exclusions.
Since the update I now have 3 flood sensors that have “Device Broken. Please remove and try to pair the device again” I’ll attempt to pair again soon and redo the associated device scenes.

Currently I have 55 devices installed. Tried adding three more devices, two with Smart Start.

Aeotec Smart Switch 7 - The Ezlo Plus tries repeatedly to install with Smart Start but fails every time. Tried manually but installs without S2 encryption and mistakenly detects it as a wall switch.

Aeotec Range Extender 7 - Tries repeatedly to install with Smart Start but fails every time. Tried a manual install but that fails as well, freezes at 5%.

Zooz Zen 16 Relay - Inclusion stuck at 5%. Will not install

The firmware update had some success at getting the Ezlo Plus into the include process, about 30% success rate now but it looks like nothing will include properly once the process starts. Exclude has about a 5% success rate.

I’ll put in a support ticket to get my firmware down graded.

Support removed the 4 dead devices that would not delete. Thanks for the quick response.

2 Likes

Hello JimMac

Thank you for your feedback. We’ll get logs from your hub and investigate the issues you faced.
We are planning to release a new version of FW next month with some fixes for issue during device exclusion.

While your looking at the logs check out why various devices don’t always respond to commands from the app. Sometimes they work and sometimes they don’t.
Scene controllers are the same way. I have minimotes and a Zooz 700 Series Scene Controller ZEN32. Most of the time it refuses to run any scenes.

I’m more concerned about the include issues, not as much the exclude.

Hi Jim!

Please go ahead and try to include any device and also try to operate the devices you mention that are not working, please let me know the specific time you did it.

OK, you should now have the times that devices failed to respond to the Android app and Smart Start failure to add new devices.

Looking through this forum I noticed ryantatum20 is also having issues with devices not responding.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules