Ezlo Plus flashing yellow, inclusion/exclusion issues

I purchased an ezlo plus hub to manage door locks and zwave repeaters, and flood sensors in a small boutique hotel property. Once I reached approximately 25 devices, Ezlo hub began acting erratically. The inclusion/exclusion process repeatedly fails to initiate. Devices and door locks time out before successful inclusion. And the yellow flashing led indicating cloud connection issues keeps coming on then turning back to blue.

The Ezlo is connected to my network over wifi. There’s strong signal everywhere. I’m carrying the hub and plugging it on each floor so as to pair the installed door locks with the hub almost touching the lock.

I have another 20-25 devices to add and the hub is just barely allowing new devices. We rely on API integration with our property management software to manage PIN codes and door locks, so this is urgent to my business.

I’ve moved from Vera to smartthings because Vera support was being discontinued, then I left smartthings and went back to ezlo because smartthings had similar issues once I reached the 25ish device threshold. This despite numerous sources saying a hub can add up to 100 devices.

Is there really a device limit? Does it have to do with the processing power or memory of the Ezlo Plus Hub? Is there a recommended alternative hub that can easily handle a high number of devices?

Can anyone please help? I’ll be grateful for any assistance or tips.

Hello @Issmat!

The capacity of the controller is actually limited by the complexity of the devices you’re trying to add, as well as different factors that are attached to their functionality (parent and child devices, energy monitoring reports, device settings). So, it’s accurate to say that the number of devices can variate depending on how complex the device is or the nature of the device you’re adding to the system. The majority of Z-Wave devices can adjust their parameters to tweak them according to the system needs or your operation needs. To get more details on what might be causing the unit’s disconnections and instability, we need to take a closer look at your network and controller logs.

We currently have a support ticket under review. We’ll let you know via e-mail and follow up on this forum thread for updates and steps to be taken as soon we’re done checking it!

1 Like

Thanks. We used to be able to ping devices in Vera. How do we do that in Ezlo?

Hello @Issmat!

Devices on Ezlo controllers can’t be exactly pinged but polled using our API tool. Different values such as reachable status and z-wave nodes can also be checked from it. In case you want to find more information on how to use this API, we kindly suggest you take a look at our API commands documentation and API tool.

Please also let me know if you need more details on how to poll the device using this tool if need!

@slapfrost Thank you. I’m not a programmer/developer but I’m comfortable following technical directions. I don’t think I can figure things out on my own using the API documentation.

There used to be a button in Vera in the device settings for each device to poll the node and that used to wake up my locks and get the latest battery status. I take it that Ezlo doesn’t have a user friendly button like that, but if you can post the exact steps or the http request I should use to achieve the same then I can do that.

An update to those following or have the same issue. After spending a very long time with support (who were very helpful and patient), they were unable to figure out what is wrong with the hub. As a final resort, we decided to reset the hub and delete all devices, which I then proceeded to painstakingly re-include into the network.

My implementation is in a commercial space with 6 floors containing about 25 zwave locks, 20 zwave signal repeater/extender plugs, and 12 zwave light switches. All the devices (other than the plugin repeaters) are already installed in doors and switch outlets and can’t be easily moved to where the hub is, so I carried the hub onto each floor.

I decided to start by re-adding the locks first since they’re older S0 locks and don’t have the issues that the S2 devices can sometimes cause with some hubs. On each floor, I plug the hub and move it so it’s almost touching the lock. I wait several minutes (some times up to 10 minutes) for the yellow flashing to stop and the hub establishes a stable connection to the cloud through the (very strong) wifi network in the area. The connection, however, is never stable and continues to be erratic and drops off intermittently. By the time I’m able to convince the hub to enter into exclusion mode to unpair the lock, then inclusion mode to pair it as a new lock, I’m usually spending 20-30 minutes just to do that.

With a fresh reset of the hub and zero devices on it, the first couple of locks are paired very quickly, within 10 seconds of the 60 second inclusion window that the Ezlo hub allows. But as I add more locks, the start of pairing takes longer and longer. Also, as I unplug the hub from one floor and replug to power on the next floor, the time it takes to connect to the cloud also gets longer and longer, requiring multiple restarts.

Eventually, after approximately 10 locks have been added, pairing takes 55 seconds to begin. Sometimes the whole 60 seconds lapse before the pairing sound on my lock comes on, but by that time the hub had already timed out and I have to begin the painful process of exclusion and inclusion again, with the hub continuously disconnecting and reconnecting to the cloud at random, and requiring multiple restarts of the hub and the phone app.

At about 15 locks I gave up. The hub was flashing yellow constantly and not connecting to the cloud at all. It was taking nearly 45 minutes to add a device. I went back to the office and plugged the hub there and left it for a whole day. The following day it looked like the hub stopped flashing and had a stable cloud connection. I started pulling locks out of the doors on each floor and bringing them to the hub in the office. Now they were still taking 55 seconds or more to pair, but the hub was stable enough and did not require multiple restarts. The exclusion and inclusion commands from the phone app were triggering the hub correctly.

After adding the remaining locks at the office, I reinstalled them on the various doors throughout the building. I then pulled all the zwave repeaters and brought them to the office to add to the hub. This also worked fine (taking nearly the entire 60 seconds to pair). I then distributed the repeaters, healed the zwave network, and tested that all the locks were receiving a signal from the hub via the repeaters (i locked and unlocked them successfully, and added PINs from the app).

Unfortunately, when I returned the next day, around 30% of the locks that I had added and tested successfully the night before disappeared from the network completely! They were still on the doors and the pins worked as before, but they were gone from the controller. I pulled out a few locks, brought them to the controller again, reset to factory settings on the lock, then excluded and included the lock again. It showed up on the controller and was working fine. I installed it on to the door and tested like the night before and it worked as expected. The following day, the same thing happened. Those locks disappeared from the controller device list.

I’m currently stuck as I’m not able to complete my setup, and I’m not able to find any information on how to view the error or debug logs of this ezlo plus hub that might give me a clue as to what happened overnight that disappeared those devices. I suspect that an older network backup is being restored automatically, one that didn’t have those locks on it yet. But I’m not able to confirm this.

Hello @Issmat

You can use:

{
   "method":"hub.device.check",
   "id":"_ID_",
   "params":{
      "_id":"deviceId0",
      "check":"status"
   }
}

Replace the deviceId0 with the device ID you want to check.
To get the Device ID, you can use “hub.devices.list” under Commands.

@Alvaro_Ochoa Thanks. I’m also still waiting for a call to resolve the disappearing devices issue. If not today, can we schedule a specific time for tomorrow?

Hello @Issmat

What is the FW version number of your controller?

@Max the Firmware version is 2.0.36.2167.3

1 Like

Hello. We are still waiting for answers or support for this issue. The Ezlo Plus is setting lock codes but not enforcing the time restrictions. Codes are active as soon as they are set despite being restricted to begin working at a future date, and they don’t expire when the expiry date and time pass.

This isn’t a lock issue, as the Vera Plus hub we have is able to set codes and restrictions properly for the same locks when we unpair the lock from Ezlo and pair it with the Vera hub.

Hello @Issmat ,

There is a chance we need to improve the integration level with your locks. I’ll follow up with you through the support ticket we have currently open.

Regards.