Ezlo Plus devices not working with Alexa

for Matter, we will provide compatibility with matter enabled devices and if you choose to use those devices, we will have a cost effective hardware just for the matter protocol.
This way you can continue using your existing hardware and simply add Matter as an add on and use MeshBots to get them automated together.

Don’t go changing the thread subject now! Eyes on the target!

How is QA going for the Alexa integration?

1 Like

I removed this review in support of the developers’ situation but please help.


asked the dev team to provide a full report here…expect it shortly.

1 Like

Hello all,

Let me share with you the latest updates on this topic.
Last month we made an investigation into the issues that our community had reported and we made some fixes on our Cloud.
Last week, Nov 28th, we deployed the fixes for unresponsive devices in Alexa to our live service. The fix improved interactions with Alexa. However, our users and QAs reported that the issue is still reproducible in the Live environment but is intermittent. We are gathering new info on this issue and implementing a new fix for voice assistants. I will provide more specific details to you on Friday, by the end of the day.
Sorry for keeping you waiting so long for this issue to be fixed. We are allocating more resources to get it done starting Friday.
I’ll keep you informed on our progress in resolving this issue.


OK, experienced what you are describing but also my list of devices here:

Is not the same list of devices as what is actually in my Ezlo and working fine in my Ezlo.

For example, if I delete a device out of my Ezlo, it still shows up on that gervera.com Alexa management page I linked above!

1 Like

Thank you for bringing this up. It was confirmed that some old (deleted) devices still being visible on the Alexa page. We are investigating this issue.

1 Like

I have some good news to report. I went back to the Manage EZLO Alexa, and it was able to find my devices, which are now showing up in Alexa and working there. Thanks for working on it! When I go to manage my devices though, I can’t get out of it and it says something went wrong so there is still some work to do there, but glad that the connection is now working for me.


Well, I’m not sure now what works and what doesn’t work. I do know that I was able to find 22 of my devices in the Alexa app on my iPhone. It looked like the list was good, for the most part, and I was able to rename some of them and Alexa would operate them by voice.

I had two labeled “Floor lamp” on the app. I selected one of them, and after the screen came up saying, “Waiting for EZLO Smart Controller”, it said it was off. I touched the “back” icon, the screen refreshed on its own, and the second one disappeared. I then selected one of the duplicate “Fan Light” device and the screen came up saying, “Waiting for EZLO Smart Controller”. This time the duplicate remained. But both devices do operate the fan light, so I guess we’re good.

I then went to the home.getvera.com page and browsed thru the “Manage Alexa Ezlo” list of devices and not nearly all of those that were finally working were there, so the list definitely was not current.

I did try updating the list and was able to check and uncheck devices, and I was able to “Finish”. When I clicked on “Finish”, it took close to 30 seconds for the screen to begin to update and then another several seconds to complete the process.

So, at this point, the Alexa app does control most of our devices but there’s no real rhyme or reason how the two apps can be managed. The hand-shaking between the Alexa app and the Ezlo app is minimal, at best.

I am going to claim about 95% success, now. I created a spreadsheet and hand entered all of the DEVICES and SCENES from the Vera app on my iPhone, that works, and has worked for the most part, all along. In the second column I entered all of the DEVICES from the Alexa app on my iPhone. They are actually 100% matched with the list on the Vera app. In the third column I entered all of the DEVICES from the “Manage Alexa” drop down menu on “home.getvera.com”. There are only five! And only three of those have names that match the Vera and Alexa apps, so that particular link is non-functional. In the fourth column I entered all of the DEVICES and SCENES from the “Manage Alexa Ezlo” drop down menu on “home.getvera.com”. There is a 1:1 match with the Vera and Alexa apps, although four of the names of devices are different. But they are all there. Also, there is a 100% match between the Vera app and the “Manage Alexa Ezlo” drop down for the SCENES.

NOTE: Whenever I tried to edit the check boxes or any of the names in the “Manage Alexa Ezlo” drop down, I had to click “Finish”. It always takes very close to 27 seconds for anything to happen. But when it finally does, it appears that at least some of the changes do get made. It is definitely not 100%, but after several tries, I got most of the way there.

That is the status of the Vera (Ezlo) / Alexa issue for me. Like I said, I may be 95% of the way there. So Vera, you are making progress!! YAY!!!


I’d love to try to add my new devices to alexa but i can’t risk screwing up the couple that actually still work.

Are you using iPhone or Android for your Vera app? If it’s an iPhone, do you have the Alexa app installed, as well? Those two are starting to talk, for me. At the moment I have all 20 devices matching in those two apps, and I went thru the list talking to Alexa to turn each on and off, one at a time. They all appear to be working. :crossed_fingers:

Hello all,

Thank you for sharing with us your feedback and noticing the improvements that we made.
Next two weeks we are planning to work on fixes on our side. As you mentioned, in some cases it takes too long to complete some action. We found some areas for improvement. We are planning to dig deeper and make Ezlo voice skills perform in a more efficient way.

My experience is a bit hit and miss using Alexa to control EZLO devices. I have not tried controlling Alexa devices from EZLO, but will give that a try as well.

1 Like

Hello Ezlo Community,
Is there anyone experiencing the same issue I’m having? Two weeks ago, I replaced my vera controller with ezlo plus. After all my devices were registered, I went to Alexa and disable my Vera Control skill and enabled Ezlo Smart Home Control. During the enable prosses, a list of my devices came up allowing me to select which devices I wanted Alexa to control. After selecting those devices and clicking Finish. I received “Your Ezlo Smart Home Control account has been successfully linked”. When I went to my device list on my Alexa app, all my ezlo devices were listed but I was not able to control them with Alexa. I went back and disable the skill and tried again. I also deleted all ezlo devices in Alexa and tried again and again with no luck.
I search the web to find out if anyone was having the same issue and I found this post. I’m experiencing a difference issue now and it may be because the bug is not fixed yet. When I enable the ezlo skill and go through the same process as I done from the beginning. This time none of my ezlo devices show up in the Alexa list anymore. Any thoughts?

Sooooo… where we at?

Hello @VeraNewbie1 @meathead88
As I mentioned a week ago, we mainly made integration work. But we are still getting issues with some accounts. It might be related to a number of devices for e.g. In order to define the root cause of the issue we are now collecting additional information that should help us to continue the investigation on specific accounts. I’m expecting to get more info next week.

Hi @Max ,
Did we get any more information?
I’ll offer up a peek inside my Ezlo if it helps.

These issues have been going on for so long that I’m moving many of my frequently used devices back to my Vera Secure so I can have voice control. My wife no longer complains now. At least I can now continue waiting while development continues without the frustration. Unfortunately not everyone has a backup Vera unit to do the same.

@JimMac Well now i’m really confused. I have the regular Ezlo and its slow and laggy and has this Alexa issue.

Are you saying the Secure does not have issues? different hardware?