Ezlo plus can't connect to cloud after network change?

I recently re-worked my home network, moving some stuff around and changing out my router. After the move everything came back up and seems to be working properly - except that my ezlo plus hub (serial 90000478) is blinking that it can’t connect to the cloud.

It is online. I can SSH into it, and I can ping various hosts such as nma-server8-cloud.ezlo.com and req-disp-at0m.mios.com from it without issue. However, it still won’t connect. Looking at the ha-uid.log shows me entries like the following:

2023-10-28 15:20:29.580635 INFO : [4/15] NmaClient will re-connect to: wss://nma-server8-cloud.ezlo.com:443
2023-10-28 15:20:29.664327 ERROR: NLWS: client wsi creation fail

While the ha-network.log show this:

2023-10-28 15:06:11 INFO  : Logs folder was changed: /var/log/firmware
2023-10-28 15:06:11 INFO  : network: at-release/2279.10-1-g89818b207c3535b08a27b4e5 [2023-07-26T11:44:35+0000]
2023-10-28 15:06:11 INFO  : network: Spread: connected to "4803" with private group "#network#localhost"
2023-10-28 15:06:11.642093 INFO : Mobile Network Configuration
APN Settings......................................0
Default APN Settings..............................1
2023-10-28 15:06:11.772167 INFO : Interface eth0 went up
2023-10-28 15:06:11.772736 INFO : Interface eth0 got internet
2023-10-28 15:06:11.843206 INFO : Internet is now available
2023-10-28 15:06:11.845608 INFO : Interface wlan0 went down
2023-10-28 15:06:11.846016 INFO : Interface wlan0 lost internet
2023-10-28 15:06:11.920352 INFO : Interface wlan0.1 went down
2023-10-28 15:06:11.940234 INFO : Waiting for WiFi driver ...
2023-10-28 15:06:22.035879 INFO : WiFi driver loaded
2023-10-28 15:06:33.435342 INFO : Enabling wlan0 interface
2023-10-28 15:06:33.435964 INFO : Configuring client_wifi interface for IzzyNet5
2023-10-28 15:06:33.436241 INFO : Disabling wlan0.1 interface
2023-10-28 15:06:33.436367 INFO : Resetting ap_wifi interface
2023-10-28 15:06:36.438585 INFO : Disabling periodic modem signal quality broadcasts
2023-10-28 15:06:36.438879 INFO : Tunnels initializing...
2023-10-28 15:06:36.439218 INFO : Waiting for new streams creating...
2023-10-28 15:06:36.439372 INFO : Tunnels initializing...
2023-10-28 15:06:36.439559 INFO : Waiting for new streams creating...
2023-10-28 15:06:48.501885 INFO : Interface eth0 lost internet
2023-10-28 15:06:48.537326 INFO : Internet is now not available
2023-10-28 15:06:48.631255 INFO : Interface wlan0 went up
2023-10-28 15:06:48.633191 INFO : Interface wlan0 got internet
2023-10-28 15:06:48.678127 INFO : Internet is now available
2023-10-28 15:06:48.721460 INFO : Creating ssh tunnel for camera: firmware_http_server
2023-10-28 15:06:48.721837 INFO : Creating ssh tunnel for camera: 61c8d5cc12a3b7124817b4de
2023-10-28 15:06:49.617666 INFO : Interface eth0 got internet
2023-10-28 15:06:56.475824 INFO : Requesting token...
2023-10-28 15:06:56.477478 INFO : Tunnels monitoring...
2023-10-28 15:07:06.477185 WARN : Cloud response getting is timed out
2023-10-28 15:07:06.477496 INFO : Wait timeout 20 seconds
2023-10-28 15:07:26.477762 INFO : Requesting token...
2023-10-28 15:07:36.484658 WARN : Cloud response getting is timed out

trying things like curl --insecure https://req-disp-at0m.mios.com work fine (that one returning the string “landing”), so the internet is definitely working.

What else can I check? How can I get this back online?

Hello ibrewster,

First, power cycle the controller by unplugging it from the power source, waiting 20 seconds, plugging it back in, and holding the reset button for 4 seconds to reboot it, also make sure that if your controller is wired to the router, the ethernet cable is well connected and totally functional.

If you already tried this and soft reset but the controller is still offline, I suggest you do a factory reset to your Ezlo controller, this will set the controller back to default state (this process is most likely going to remove the controller from your account because it will clear the whole configuration of it but you’ll make sure it is on factory default state which can solve a lot of issues).

To do so, press the reset button (the hole that is at the back of the controller) for 15 seconds (pressing for more than 20 will cancel the factory reset process). Wait for a few minutes and then pair the controller again to your network using the VeraMobile app.

Let me know how it goes, in case the process fails, please let us know and we will open a support ticket to be in contact through your email address to find a way to fix it.

Looking forward to your response

Yes, I’ve done that something like 20 times, and the hub has full access to the internet as per ping and curl commands returning the expected value, thereby proving that the connection is “well connected and totally functional”

What about the devices I have paired with it? What about the scenes I have set up on it? Are you seriously suggesting that I start over from scratch, re-pair everything, and re-setup all my scenes, just because I swiped out my router and moved some stuff around? Or does a factory reset somehow not wipe out the devices and scenes?

I guess theoretically if I took a backup first…

EDIT: Oh, right, I can’t take a backup because there is no local web interface. Taking a backup requires it be connected to the Ezlo cloud. Ugh.

Sorry, this has been a bit frustrating

Ok, narrowed down the issue: it doesn’t like the new DNS server on my new router. By telling DHCP to push it the cloudflare and google DNS servers directly, it came back online.

Still need to figure out what exactly, it doesn’t like about my DNS server (please note: DNS IS working - I was able to resolve various addresses just fine), but at least I know where the problem lies…

Sure glad I didn’t follow the advice to factory reset it… :slight_smile:

Greetings, @ibrewster

We are glad to know that the issue got resolved, one of the best option is to leave the controller decide which DNS to choose instead of pushing one through the network settings, you can also submit a ticket to support@ezlo.com if you need further assistance.

I fully agree, however in this case that broke things, and specifying the DNS server fixed them.

pls let us know when you find the root cause. thanks.

Got it! The unbound DNS server on my router had an option to “Enable DNS64 Support” enabled, which apparently has something to do with allowing IPv6 only devices to access IPv4 only hosts. Turning off this option allowed the Ezlo hub to connect as expected.

Note that the Ezlo device is getting a IPv4 address on my network, so I’m not sure why it should be affected by an option that is supposedly for IPv6 only devices, but there it is. Maybe the unbound server was returning IPv6 style responses, that weren’t working because I’m not running IPv6? Of course, I would think all devices would have been having issues then, not just one, so not sure on that.

1 Like

great find!
thank you. I have shared this with our team.

@ibrewster we are checking it now and will back to you asap.

Hello, @ibrewster

Could you share the vendor and model of your router, please?
Also, is this option set by default? Is it set like that from the box?

This is a setting un the Unbound DNS resolver, which is a Unix based tool, not specific to any router. That said, in this case it is running on an OPNsense router installed on commodity intel computer hardware.

I don’t believe that setting was on by default, no - I think I turned it on because it sounded like it would be a good thing. Now that I know it causes problems, I’m perfectly happy to leave it off.