Ezlo Dashboard not loading? And cannot edit Meshbots

I haven’t looked at my Ezlo hub setup for months. I tried to open the web UI today and it doesn’t seem to be working.

The dashboard just looks like this:

I tried clearing the Chrome Browser Cache Data and I also deleted the Ezlo Dashboard database but it was still the same.

The light on the front of the Ezlo hub was the normal Blue colour and I could ping the hub OK.

However I could not use Putty to SSH into the box the connection did not connect.

I then pulled the USB cable out of the hub to kill the power and back in again. I can now SSH in to the box again OK.

Now in Chrome the Dashboard is loading up OK and I can see the device tiles.

I then tried to edit a Meshbot rule again and that is now working again also.

I can only assume there was a firmware update that has put the Ezlo Plus hub in to a “BAD” state ?


Just checking the versions now, this is the hub.


The web UI says its version 1.61.1

And the Dashboard is version 1.1.12

The reason why I looked at the Ezlo hub was because I noticed one Meshbot (maybe others?) were no longer working.

The particular rule I am looking at now, is using the Ezlo Site Sensor Plug to detect when my Emby media server is down.

Looking at the rules trigger now the “value” is blank and True or False is not selected.

I have not done this, some update must of broken this rules trigger ?

So I am now wondering how many other Meshbot rules may have been broken ?

1 Like

It seems that over time, passing various updates/upgrades, some of the older meshbots break. I’ve seen several just fail, or keep working while being unable to edit them from the UI.

My workaround is to just delete the offending meshbot and recreate it.

Yes I think you maybe correct unfortunately.

I had to delete the trigger and recreate it and save the rule again. I was able to edit the rule again only after a power reset / reboot of the hub though.

I have not tried deleting the entire rule and recreating it however, I might try that next, as the trigger doesn’t seem to be working when I want it to.

I want the Site Sensor plugin / rule to notify me when my Site has gone DOWN.

But currently it only runs the rules action when the site is back UP again.

I have tried using both true and false in the rules trigger and both seem to behave the same way and only run the rules action when the site is back UP.

I wrote about that issue here.

I’ve just had a quick look at some of my other Meshbot rules and some of them have been affected also. Their “Switch” trigger value has been wiped blank also and true or false is no longer selected. Presumably meaning these particular rules are now broken and will no longer trigger.

It seems to be from what I have seen briefly, only related to Switch devices. mainly ones relating to Ezlo plugins or virtual switches.

Some of my other rules based on say Time schedules, look to be OK and their original trigger is intact and not affected.

I am seeing some weird stuff in long existing meshbots just recently. Missing true and false like you experienced, inverted logic in triggers, and inability to save minor changes (I thought this was fixed a while back).

Somethings run amuck.

1 Like

So how recently have you noticed these issues?

They are telling me the last firmware update was in March.

Although web UI and dashboard page updates are their own thing and may happen more frequently.

I’ve not looked at my Ezlo hub for many months, so dont know when it broke.

I see you posted about it here.

I’d have to do some more testing to see if the logic is inverted? That has happened before however in the past.

As for the greyed out save button I have seen that happening today.

Maybe this is a hint of the problem. I got an error while the dashboard page loaded:

JSON.parse:unexpected character at line 1 column 1 of the JSON data