Expression variable not available in activity SET VARIABLE

After I had a Reactor Safety Lockout ( at least I think that was the trigger point) variables are no longer available in the Activities tab. They exists in the Expressions tab, they are shown in the Status tab, they are available in the Conditions tab, but if I try to use “Set Variable” in the Actvities no variables are presented. I have even tried creating new variables but they are not available for use in the Activities Set Variable command.

I have rebooted, refreshed the browsser, restaret LUA, tried another browser. No luck. Any idas?

1 Like

If a variable has an expression, it cannot be used in “Set Variable” and will not be listed there. Variables with expressions are driven by those expressions exclusively and you cannot set them otherwise.

1 Like

Of course :man_facepalming:t2: Feeling stupid now. Thanks

That gets a lot of people, actually. I think variables would be unusable if it did otherwise, but it’s not one of those things that you think of right off the bat. You’ve now leveled up.

Been there, done that more times than I care to admit. Gary, you are not alone. :slight_smile:

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules