ExpressControls3in1 in vera edge ui7 only trips once

I have one of these: ExpressControls3in1 - MiOS

I used it with a vera 2 until it crapped out a couple of weeks ago. No I have a vera edge and am setting everything up again. The 3-in-1 is associated okay and it’s clear the the vera edge is talking to it. But the config U/I I see in UI7 looks nothing like the one shown in the above docs. I think the old UI4 U/I looked better.

All I really want to do is have every trip of the sensor run a line of LUA and I had that working great in my vera 2. Now I’ve set up a “scene” to do my LUA and I can see that part is fine when I test it. It also seems to pick up on the motion sensor trip – once.

But after firing one time, the motion sensor is apparently switching off. It seems to have an infinite “ignore trip time” set now, or something. If I press the wakeup button, it will wake up, trip, and my event will fire, but it never seems to come back on its own. I really don’t need a “scene” as the only thing I want to do is luup.inet.wget(“http://XXXXXX/vera_event?MotionSensorTrip”, 5) but in UI4 that’s how you did it. Maybe this is wrong for UI7.

I believe the problem is some default setting that UI7 is putting into the motion sensor like putting it in some single-shot mode or something, but I am clueless how to get the device configuration U/I to look right. Am I missing some plug-in that would make the U/I look right?


Have you changed the value of parameter 2, the default is to not untrip for 20 minutes, you need to reduce the setting, I believe the lowest setting is 1 minute, if you set it to zero you will get the behavior you are seeing.

Yes. I have parameter 2 set to “0” – trigger every time. It is not behaving that way though. Either setting the parameter in the Vera is not working at all or something is setting it back again after some period. I have no independent way to read the unit other than watch how it operates. Looking at the gaps between when it does trigger, the “on time” must be about 1/2 hour – it could be the default of 20 minutes.

As I said, you cannot set parameter 2 to 0 that is your problem, when you set to 0, it only sends tripped commands and never untrips, so will only report the latest tripped value. The lowest you can go and still get an untripped value is 1.

Thanks for looking into this.

I think you should be able to set param 2 to 0 to have it trip every time. This is how I set it with my Vera2 and I got consistent trips whenever it saw motion regardless of how long it had been. My lua script would run and do its thing every time. Even several times a minute. The issue I have is that that sensor trips, wakes up, sees motion, red light comes on, zwave traffic, evidently, goes by – but the “scene” never executes.

I am not sure what “untrip” means for this sensor. The vera should not need or care about the “off” event that the sensor sends to the associated units. It should run the “trip” event no matter whether an off is seen or not. Perhaps this is a difference with UI7 compared to how it worked previously in UI4

I’ve tried setting the on-time to 1 minute, which is marginal for my requirements. But I think I am getting my scene invoked now. So that is something.

Yeah, unfortunately that is just how it works in UI7, my guess is that if you really want to use the 0 setting you could probably do it if you use PLEG instead, as then you can be more selective about what variables you are watching. If you look at the advance tab on th device you should see variables like tripped, last tripped, last tripped alarm, last untripped, last untripped alarm. My guess is the UI7 is looking at the wrong variable or not updating the tripped variable correctly to determine when motion has stopped when the sensor is in the 0 mode. But you could use PLEG to just watch the last tripped time , and fire your command when ever the last tripped updates. Otherwise you have to stick with the 1 minute reset.