Eternal problems of the Vera app

i already have vera plus and vera secure for two years, and always had the same problem in the app for ios: with the app open if the smartphone switches the internet from 4G to wifi or the other way around, stop giving pars to control the devices.
and there’s another problem. working with 4g, when you open the application, it takes too long to answer.

the worst app to work with vera, is the vera app. imperihome, google home, they all work better with vera than the app itself. and I’m not just talking about options. I also say speed of response and stability


Quite true it seems, why I have used Imperihome for years it so much better than Veras own app.

And before that Automation HD app.

I’ve used Vera for over ten years and in all that time I’ve never used the Vera mobile app because its no good.

Ezlo are going down the same old route. They haven’t built a brand new Mios app.

They are instead just building on top of the pre existing Vera app and adding limited dashboard features.

Imperihome is dead and won’t work with the new Ezlo HTTP API.

Not looking good for the future of this platform.

1 Like

And because they have a brand new HTTP server API for the new Ezlo platform, pre existing half decent 3td party dashboard apps like “The Home Remote” will also die and no longer work.

And not mention all our current and working 3rd party plugins that will also break.

I don’t know who is really in charge of this new company? but they are doing lots of things backwards.

No Web GUI? Really??

Building backwards if you ask me, from mobile apps that are just rehashed versions of the bad to begin wiith Vera app.

Yet they claim the new Linux still based on OpenWRT and RTOS firmware is faster but the Vera app and new Mios app are still slow with spinning circles of death and still the dreded “Can’t detect device” red banners.


On my soap box now.

It’s been 3rd party developers who have kept Vera alive not Vera Control Ltd all these years.

Yet now most of those talented 3rd party Devs have moved on and left.

Richard and PLEG kept it alive for me. He’s gone now.

@rigpapa and his Reactor logic engine is keeping it alive for new comers.

Yet the list of now still active 3rd party Devs I can count on one hand…

As talented as they are I’m losing faith and not sure I can continue to rely on a half baked platform and still rely on such few 3rd party devs.

We needed 3rd party devs for logic engines.

We needed 3rd party devs for nice front end dashboard GUIs.

And what I’ve seen from Ezlo so far this pattern doesn’t seem to be changing…

Early days yet? Perhaps but it’s not going in the direction I expected.


@cw-kid i can’t disagree with what you’re saying at all. Ezlo will be the death of of what made Vera reasonably successful. I will keep my Vera as long as these handful of 3rd party devs are still here, but once they’re gone so will I be. The activity from the core forums members has been on a huge decline and those are signs of long time users abandoning ship.


I want a decent UI7 replacement Web GUI, UI8.

Needs to be as functional as UI7 is now for setup and configuration of the system and devices, on a big computer screen and much improved.

As for the Vera mobile app, you can keep it.

I dont want to use it or see it. I dont want to use a mobile app for setup and configuration of the system. OK for newbies maybe at a push.

I do want to see a brand new mobile dashboard kiosk app like Imperihome but better.

Why configure the system on a mobile phone?

Why have other family members having access to all Configuration options in a mobile app?

Don’t want it don’t need it.

A front end locked down control GUI dashboard app with pretty visuals and graphics is all I want to see on the front end.

Backend configuration is only for me in the Web GUI.

Who is the CEO of Ezlo Inovations?

We’ve not seen him on the forums yet.

Maybe I should jump ship and learn Home Assistant.

I am sorry to hear you have such problems.The behaviour you are describing is not normal.
The app should open and be controllable really fast. Please see my test video here:

Also you should not have any issues controlling devices when switching from wifi to 4G and vice versa:

Let’s investigate this further. Could you give us more details like firmware version and App version? Would you agree to create me a test user on you account to debug what is making the app slow?

Thank you,

good afternoon. I already had some iOS smartphones (iPhone 7-Plus, iPhone SE, iPhone 11), and several Vera control (Plus and Secure), and I always remember these problems. the problem of switching from Wi-Fi to 4G has always been there for two years. the update speed of the app when opened in 4G in your test is 3 seconds (since you press to open the app, until the updated devices appear) on my iPhone 11 is 13 as you can see in the video. I never got less than 10 seconds. when I open the app with the Wi-Fi in the house it’s 3/4 seconds.

1 Like

You should not have such delays. It looks like a connection issue with the relay servers.
Please open a ticket on customer care.

I suppose it’s time to just say it.

I’ve given up. Their engineers are great, smart people, but engineering leadership is, in my opinion, completely failing them. Do you recall the promise of an August general release? We’re almost to October… Promises made and broken again and again and again. Bugs and holes. I’ve lost my will to chase and press for what I need to get an eZLO version of Reactor done. I stopped in July, after three months of reporting bugs and holes, literally begging for changes, and waiting months for fixes, which came piecemeal or not at all (but “it’s on the roadmap”). The quality of what I can produce is limited by what they produce, just as it is with current firmware. After more than two years, they’re still not ready, and IMO it’s simply because of leadership failure. I can’t see that there’s any forethought to anything, from the start to today. They’re playing whack-a-mole when they need to be playing chess.

Still no sign of that. No sign of any mechanism to build GUIs for configuration like Reactor’s configuration editors. But there’s effort on 100 other things. Following these threads of late, it’s clear they are building something with so many moving parts that it’s fragile beyond belief… if it’s not a firmware bug, it’s a mobile app bug; if not that, it’s a problem with the cloud infrastructure. Distribute work across multiple controllers? How about something reliable on one?

I’m off building for other platforms now. I’ll support the current firmware as long as that’s a thing, but I won’t touch the new stuff again until I think it’s ready, I’m guessing at least another year still until it’s an equal to the current legacy firmware and a viable platform where third-party developers can build good quality products for it.

P.S. If I end up getting banned for sharing this opinion, you can use Github issues for each plugin for questions and problems; there’s also an email address in the Troubleshooting section of any ReactorSensor’s tools tab.


Can’t blame you, as a non-dev but an avid user I have been let down too many times to even care anymore. My goal is to make my VP useable for the foreseeable future as I will NOT be switching over to Ezlo ever.


EZLO are going to be doomed without a decent logic engine. No PLEG no Reactor.

I’m not sure if they can create their own.

If they are not properly listening to their star 3rd party developer and not implementing the required changes then it’s a none starter.

The 3rd party developer base is already very low in numbers. Ezlo should be giving you guys top priority and access to resources needed internally.

I can’t see all this ending well, maybe I’m losing my patience with the apparent lack of progress in all areas of the new platform.

I really hate to say it, but maybe it’s time to start looking around at other platforms.

I have generally been very happy with Vera for many years, but as I said it was really the 3rd party developers that made it so.


Thank you @rigpapa for sharing your opinion.

They gave me access, of a sort. The problem was that changes were coming too slowly. Everything is done in two week sprints. And you’d think that means you’re two weeks or less from getting your add/fix, but no… if you’re talking about something during sprint A, it won’t be scheduled for implementation until sprint B at the earliest — if you’re a week away from B’s scheduled start, that’s three weeks before you see your change. If it misses B for some reason, more delays in two-week increments. You can’t make progress that way.

So, I had access, but the kind of access and the way we have to work with what they’re doing, it’s just too difficult to be productive. And from the start I had the distinct impression that nobody involved on their end wanted to be, they just want to do their stuff, their design, their ideas. They have more than enough to do without the likes of us buzzing at them. The disdain for third-party developers is palpable, just as it was before. We’re not seen as enhancers of the platform, rather quite the opposite.

Message received. I’m moving on.


This is a big blow for both Ezlo and the community.

As you know I use PLEG not Reactor but it was my intention to switch to using Reactor on the new Ezlo hub at some point.

Perhaps Ezlo feel they can build a better logic engine themselves.

Anyway some big decisions to be made now.

This Z-Wave & Zigbee USB stick and a Raspberry Pi 4 might be on my Christmas wish list now!


Since you already have a raspberry, moving to openluup is easy. You’ll do in 3-4 hours and you’ll keep everything you have. This will stay forever, even if they will not update or enhance the firmware, @akbooer will still maintain openluup, since it’s its own runtime platfofm :grin:


And I will keep all of my plugins that run on openLuup running there as well, including Reactor.

1 Like

As often happens, you just managed to say in one go everything I’ve been thinking these past few months. (Was also keeping quiet lest the 1000-Year-Ban Police not select me as their next victim. Ugh!)

Even as a beta tester, it’s practically impossible to believe that anything I’m doing here is making a positive difference. The “testing” program is so slipshod that none of us seem to know what’s expected of us. There’s no bug-tracking in place, no feedback loop, no chain of command, no suggested protocols, etc.

I really feel for you Developers at this point. No one would blame you for a moment being as frustrated as your post suggests. Clearly you are not alone!


Indeed so, with the help of others.

Vera was central to my HA systems, but needed help. In time, Vera, for me, became just a Z-wave bridge. Now Vera is dying (from neglect, mostly?) but we don’t need it any more. There are other Z-wave bridges, and ZigBee, and MySensors, and WiFi, all of which can be handled inside a LAN with no cloud access required.

I don’t think the current Ezlo offering is something I’m ready to tackle in terms of integration, but there is already an openLuup plugin for it, courtesy of @reneboer.

Curiously, this very week, one of my VeraLite systems has died. It certainly won’t be replaced, and all of its functionality, save a couple of pulse counting meter readers, will be removed from my Z-wave ecosystem.


Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules