Emulation mode error message

I added a Motorola Scout85 to my home, and added it to my vera. The local URL for a jpg is just http:///cgi-bin/jpg/image.cgi . I added it like that, but whenever I go to the video, I get the error “You are seeing the video in emulation mode, click on Retry to load it again in continous mode”. Does anyone know what that error means, and how to ignore it, because the camera image works fine if I close the error as far as I can tell.

There is also an mjpg url (axis-cgi/mjpg/video.cgi), but that doesn’t work in the vera. Not sure how I would get that to work, but I’d ideally like to get the snapshot version working first.


This new error popped up in the newest firmware. As far as I can tell, “emulation mode” is vera trying to emulate a live video feed by streaming/refreshing stills. I think they’re working their way toward having full h264 streaming from cameras that support it, and the emulation is a fall back mode.

Thanks - you are right. I didn’t even notice that it gave the same error for all of my cameras. I assumed it was just a problem with the new one.

Anyone know how to get rid of the message - it’s a nuisance. And it’s spelt wrong.

Hi Martin,
Once again it’s me, as you can see, i’m trying to fiw my problem with the “snapshot”’ or “videostream” cgi.
As i’m looking where this problem cancome from, i discovered that you had the same problem than me on this topic.
Even if we don’t have the same camera, i’m facing this error message “You are seeing the video in emulation mode. The camera doesn’t support or has trouble loading up the continuous streaming.”
And on the background, sometimes it works, sometimes i got a “Invalid Credentials”, switching one to another, and getting by this way an annoying list of alerts in my dashboard “device connected”, “device disconnected”…
Did you manage to make it work?
Do you think i should “downgrade” UI?
I’ll come back to you in the other topic “dropbox camera plugin”, cause i’ve found something.

Even I have the same issue, sometimes the feed works and most of the time i get “Invalid credentials”,

is the problem in Vera or the firmware of the dahua IPC?

Looks like this hasn’t been resolved yet. We have a number of foscam models (both SD-MPEG and HD) setup within Vera for testing purposes and they all result in a “emulation mode” error. There seems to be a bit of a memory leak as well. While using Google Chrome and letting it sit there on that page for 20-30 seconds, the page refreshes to an error showing that Chrome has ran out of memory. Although, most of the systems here have 30-50 tabs open at any time, it still takes a lot for this to happen as we increase the memory within chrome. I remember them having troubles with the cameras back in UI5 as well though. They never really worked 100%. Might just be a Foscam issue though.

I?m getting the same error using two different Bosch cams (flexidome 2000 & Flexidome 5000)

My cams are set as 720p & 5MP

This is rather a notification prompt introduced a while ago, for cameras that are not using native h.264 full frame stream.

Third party cameras are working the same as always, just check the box for not showing it again. This is not affecting the system in any way, slow it down, or else.