Elzo Plus Scene Creation

Have been a Vera user for a number of years. Bought an EZLO plus shortly after it came out but delayed moving everything over for a number of reasons. Finally made the plunge today, but I am have trouble adding a scene. I create the trigger and then add the action, but it does not let me save. The done button has no effect. Suggestions?

Just wanted to add that I went to try creating a meshbot. Same problem there. I got all the way though and could not save it!

are you using the web interface?


Thank you for bringing this to our attention.

As mentioned on a previous response, please make sure you’re using this link https://ezlogic.mios.com/

Secondly, we suggest you log out and log back in. You might have to do it a couple of times. For better results, log out clicking the user icon on your dashboard on the top right corner.

Then log out from the button on the bottom

Then log back in. If this does not help, please describe the scene that you’re trying to create and the type of meshbot for us to test.

Feel free to open a ticket with us at support@ezlo.com so we can look further into this.

I tried using the app and was unable to save a scene. Then I went to the web interface and tried there. Could not save there either.

We’d like to look further into this. Did you try power cycling your device after you were unable to save scenes from both ends? If not, please give it a try.

On the other hand, please open a ticket with us at support@ezlo.com stating your controller’s serial number and we’ll validate a few things.

Will power cycle it before I head out and will let you know.

Hi @Grwebster

We will be attentive!


I have had this issue since before they updated their web portal I am also have issues with scenes that I can edit and save and scenes I can not edit because they will not save.
Aslo with any Scene that uses motion and or time to control a device it may work once but after that anyone guess

So this is not an issue unique to me. This is a deal breaker if it happens much. At this time I can’t seem to add any scenes! I cycled power with no luck. I also seem to be in a position where I can’t fully remove my Alexa integration nor can I add it back in!

Even a simple scene like turn on a light using a time of day trigger will not work. I put one scene in the change house modes after the lock is unlocked by screen entry, but since then nothing.

Hello everyone,
Thank you for bringing it up. Sorry for you facing this issue. We are checking the issue reported on scene creation on our side. We are trying to fix the issue asap. I’ll keep you updated on our progress.

I gave the serial number with an email, so you should be good to go in and look.

1 Like

Hello @Grwebster
Thank you for providing us with the info needed. We weren’t able to reproduce this issue on our side. Now we are investigating logs from your hub. It might be an issue related to your specific setup or controller. I’ll update you as soon as we the root cause of the issue you faced. We are building a new integration and automation system that differs from Vera home automation. We are putting building blocks one by one and improving every week. It takes some time to remove all flaws that we’re getting during this journey. I’m really sorry that the issue you faced make you think that our system is not worth ti be used.

1 Like

I can’t create any scenes so no controls can be added.

If you are on an iPad, rotate the iPad to portrait view, the save button shows up at the bottom.


Thanks for the suggestion. The button is there but pressing it does nothing. Will try portrait mode though!

Actually putting the screen in portrait mode works! The button shows in landscape mode in the app, but does not work there.

Sure that’s a bug I reported to them ages ago, looks like it never got fixed.

@Grwebster can you tell this problem occurs on which vera mobile app ? IOS or android ?