EDF teleinfo

no, I don’t have a connection via the USB port
in the logs; only the error:
LuImplementation::StartLua 73 I_TeleEDF.xml failed to open port <0x2b45b680>

drop down for Serial Port connection :slight_smile:

  • none
  • ftdi_sio ( which corresponds to the usb port )

via a Windows PC and hyperterminal, the frames scroll well however.
so really a plugin config problem

And all the other settings are correct? Speed / Data Bits / Parity / Stop Bits etc.

If you had this Vera UI5 plugin working OK in the past, then one should think it should still connect and work now.

yes the parameters are good

yes it worked
but I wonder if there is not a modification to be made either in 1 of the files or in a variable

but what …

In the images above, the TeleEDF is device 73. The variable “IODevice” is set to be device 3. ie device 3 is the serial device and device 73, the TeleEDF device, makes use of this serial device. Can you post an image of the “Advanced” tab in device 3. The serial variables should be set in there?

1 Like

here is device3

> <device id="3" device_type="urn:micasaverde-org:device:SerialPort:1" room="0" id_parent="2" disabled="0" device_file="D_SerialPort1.xml" impl_file="" manufacturer="" model="" mac="" time_created="1441907684" category_num="13" subcategory_num="0" embedded="1" invisible="1" altid="usb-rt3883-ohci-2" name="ftdi_sio" ip="" local_udn="uuid:4d494342-5342-5645-0003-000001cb5a70" commProv="rs232">
> <states>
> <state service="urn:micasaverde-com:serviceId:HaDevice1" variable="IOPort" value="" id="0"/>
> <state service="urn:micasaverde-com:serviceId:HaDevice1" variable="Protocol" value="RS232" id="1"/>
> <state service="urn:micasaverde-org:serviceId:SerialPort1" variable="vendor" value="403" id="2"/>
> <state service="urn:micasaverde-org:serviceId:SerialPort1" variable="product" value="6001" id="3"/>
> <state service="urn:micasaverde-org:serviceId:SerialPort1" variable="path" value="/dev/ttyUSB0" id="4"/>
> <state service="urn:micasaverde-org:serviceId:SerialPort1" variable="baud" value="1200" id="5"/>
> <state service="urn:micasaverde-org:serviceId:SerialPort1" variable="databits" value="7" id="6"/>
> <state service="urn:micasaverde-com:serviceId:HaDevice1" variable="LastUpdate" value="0" id="7"/>
> <state service="urn:micasaverde-org:serviceId:SerialPort1" variable="parity" value="even" id="8"/>
> <state service="urn:micasaverde-org:serviceId:SerialPort1" variable="stopbits" value="1" id="9"/>
> <state service="urn:micasaverde-com:serviceId:HaDevice1" variable="Path" value="/dev/ttyUSB1" id="10"/>
> </states>
> <ControlURLs>
> <service_3 service="urn:micasaverde-org:serviceId:SerialPort1" ControlURL="/upnp/control/dev_3" EventURL="/upnp/event/dev_3" serviceType="urn:micasaverde-org:service:SerialPort:1"/>
> </ControlURLs>
> </device>

The file I_TeleEDF.xml on line 5 says the ioPort is port 23. However in the read out for your serial device 3 above, IOPort is shown to be empty. Should it be 23?

I deleted: 23
in I_TeleEDF.xml
I get error: missing port
luup_io_write NULL port 0x1043d50 size 4

I tried with: 3
error :
IOPort::Connect connect -1