Ecobee Thermostat (by eZLO) Plugin

There’s a newer plugin app called Ecobee Thermostat (by eZLO) .

The instructions call for you to install the app, then add the Ecobee thermostat by adding devices (like you would a Z-wave device). Add Device>Thermostat>Ecobee. Then provide credentials to link your account.

Has anyone had any luck installing an Ecobee thermostat using this plugin?

It says it’s by “eZLO”, but I doubt it’s by Ezlo Innovations.


Where does one find this plug in?

From a browser (not the Vera app). Apps>Install Apps> search for Ecobee.


@Lonestar10 I just saw this, too. I have the original ecobee plugin currently and it seems to work pretty well. Have you installed this new version and compared?

This has me hunkered down in classic “If it ain’t broke, don’t try to fix it” mode, so I’ll wait until someone else gives the ezlo version a try. But I will gladly admit that the “classic” ecobee plug-in (which I’ve used successfully for 3 years) is not without its flaws, so there’s always been room for improvement!


Yes, the original works OK, except for having to get new PINs all the time. The new version, once installed, apparently will place ecobee under Devices>Thermostats where it can be installed by linking accounts. But it never worked for me. It never appeared under Devices>Thermostats.


Ah that’s a solid point, interested to watch from the sidelines lol. I’m with @LibraSun where things are working so nervous to touch anything haha.

For example I just had to reconfigure an ecolink door sensor (read: delete/force unpair, then repair, then ‘configure node now’ multiple times to get things happy), and as I took a breath the last reload said my connection to Envisalink alarm panel was down. Which is active on the network and nothing has changed with it whatsoever. /sigh…


Just noticed this plugin today as well. Has anyone tried this yet?

1 Like

Just saw it today.
The old plugin only partially worked for me so did not build any scenes around it. The old plugin would stick at mode auto. Could not change to cool or heat. I rely on Alexa to manage the ecobee as long as the mode stays either cool or heat.
I uninstalled the old and installed the ezlo version. It says it supports VeraPlus > 1.7.4970 .
Well my current firmware is = 1.7.4970 i.e. it is not greater than 1.7.4970 and there is no update available for firmware yet.
As per instructions, looking in devices -> add device-> thermostats… There is no entry yet for ecobee. So cannot authenticate it.
Additionally no help info for this plugin from the help link of the plugin. It just takes you to the ezlo web site.
Will wait and see once next firmware is available. Not worth my time at this point to deal with tech support for this.


Good info - thanks for sharing! If I had just blindly installed and removed the old one, I would have to had to rebuild everything. So odd that this plugin would be released and require a future firmware as a pre-req.

My firmware is 1.7.5186. Still no listing for ecobee, still no way to link the app, still no help file. I did blindly remove the old one before adding the new but I don’t use ecobee through Vera enough to bother reverting and rebuilding.

An earlier poster suggests that the app is a fraud – that its not by Ezlo at all. At first that didn’t occur to me; now I tend to agree. But if so then why does Ezlo allow a fake in the Ezlo system to fool Ezlo’s customers by passing itself off as an Ezlo product? Slightly changing the name or logo doesn’t give the app legal immunity. Is the answer that Ezlo doesn’t bother to check these things and doesn’t know or care of the problem?

1 Like

@Sorin, can you help us get to the underlying truth here? Rumors (at least rumors surrounding apps in the App Store) are bad mojo.

1 Like

Hi guys, I’ve asked for clarification.

At the first sight …it’s an oversight as it should have been included in the current release. :X

However, I’ve been given these instructions to pass on, as a temporary solution until this is addressed in the upcoming firmware.

1. Make sure the plugin is installed
2. make a request to the controller like so: (on local connection)
http://vera_ip:3480/data_request?id=lr_get_ecobee_auth_url (Replace vera_ip with the actual IP of your Vera)
3. Then put the link from the result in a web browser and you should be able to account link.

I hope this helps.

1 Like

On Step 2, I get a return of “No handler.”

Make sure the plugin is installed before running the request. (correct plugin)

I switched over to the new Ezlo plugin yesterday, as I dont really do any automation with my 2 thermostats and vera. It seems to work well for temp reporting, humidity reporting and control but the occupancy/motion sensors dont seem to report back status at all. Almost all my sensors show active right now on ecobee, but not a single one has shown any occupancy on Vera. I know there is usually a delay between sensor detection and ecobee reporting, but once ecobee reports it, I would expect vera to also report occupancy at the same time.

This always worked correctly with the non-official plugin. @Sorin @mcvflorin, and ideas/suggestions to get it working, or do we just have to wait for the next firmware?


Following Sorin’s suggestion has taken me this far: ecobee tells me that I’ve added the new app and the app tells me that it has created a new device called “ecobee.” But that device says “Authorization Required” and does not operate. Re-authorizing the app, deleting and reloading the app, and using colorful language have not solved the problem.


Hi guys, there might still be issues or bugs with the existing level of integration. Unfortunately there’s nothing we can do at this point but if you want you can send tickets to our Customer Care team so they can collect logs and send them to the development team, to be addressed with the upcoming 7.32.

LE: Thank for you everyone that reached our customer care team.
PS: We’ve update the plugin today V1.2, which also fixes some auth issues among other things. You should try it out.

You don’t have to go on the new device created by the ecobee plugin to authorize (this should be invisible). To authorize you should start the wizard with the mentioned request.

Sorin, thanks for your help but on my system neither 1.1 nor 1.2 creates a device from which to initiate a wizard. The “Thermostats” section on the page for adding devices lists no ecobee device; searching for “ecobee” returns “no results found.” The “device” I mentioned was the one that the app’s page (under My Apps) says it creates; it was indeed invisible until I changed its parameters to make it visible, just to make sure that it existed at all. For me, at least, 1.2 has not changed anything.

1 Like

I have tried the 1.1 and 1.2 plugins. I have successfully generated the request which links my Ecobee account with my Vera.
An I/O device is generated with an On/Off option, however the Ecobee thermostats do not appear on my devices list in My Vera app/portal. The I/O device number is not the same as the device number quoted in the App. App says plug created device #433, but the device that appears in device section is device #431.
What am I missing ?

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules