Dongle doesn't recognize HA14 dimmer

My Vera Dongle doesn’t recognize HA14 dimmer. I’ve tried all combinations: turning it ON/OFF, dimming light, etc… I have 6 HA20 dimmers that Dongle recognized without problems and work great.
Any suggestions?
Thanks in advance.

Can it be simply busted?

I got one appliance module, which has Z-Wave part not working - it can’t be included into any network as no controller can see it. The manual part of the appliance still works, though… :slight_smile:

Possible. I need 15 more switches for the new house and am very hesitant to go with HA14 after this experience. Are you aware of some other cost effective Zwave dimmer that is compatible with VERA?

Did you try excluding it, then including it?

No, I just tried to include it and dongle doesn’t recognize it. How can I exclude it?

The same way you include it, but you need to put the dongle in exclude mode by holding down the button for 3 seconds first.

HomeSettings line isn’t exactly high end, so I had quiet a few HA* modules with not working z-wave.
But the best think about them is that all you need is a single email to their support to receive a replacement.

A good practice when adding devices to a network is to delete the device first - then add it - I have seen numerous devices from different manufacturer’s come out of the box with Id’s (a device cannot live on two different networks) 8)

I have the same issue with one of my HA-14’s… my vera recognized the dimmer, however can’t configure it. Comes back as a red sprocket unless my vera is within 5 feet of the dimmer… weird…