Disaster - Upgrade from 1.7.3423 - 1.4.4001

As many others I have been very reluctant to upgrade my system as previous upgrades has resulted in massive problems and work to mitigate (I have two Vera controllers in my home). I have been with Vera for several years after trying out HomeSeer. I left HomeSeer mainly because it was running on a Windows PC which turned out to be to difficult for the family to handle in my absence. In addition I experienced many problems in the Z-Wave network resulting in loss of nodes and communication problems (this was several years ago HS2).

Recently I have experienced:

[ol][li]Instabilities like sensors not triggering as they should, functions stop working for short times for no apparent reason[/li]
[li]Ghost nodes suddenly appearing and polluting the UI and no possible to remove without serious work[/li]
[li]Inability to include legacy battery operated devices (MERTEN push-buttons)[/li]
[li]Major problems each time I upgrade the firmware[/li][/ol]

This has lead to the conclusion of upgrading from the older firmware to 1.7.4001 (7.027)

I have stayed with Vera because of the reasonable cost, this excellent forum, the availability of plug-ins like PLEG , Reactor, etc etc. in spite of all the trouble with upgrading my units. Without these plugins the system is just a toy in my opinion and not suitable for real automation. Vera also lacks a good configurable fronted to run on Android or IoS. I am eagerly awaiting the promised effects of the acquisition last year and the first upgrade soon to be released and the UI8.

My upgrade ended up in a non working system with an out of memory error constantly reloading LUA. I was for the first time not able to fix this and contacted Support. They SSH’d into my Vera and seemingly got it to work. After I moved it back to its permanent position I was not able to access it after the boot and only the LED’s for Power and Internet are on. It is possible to access it through SSH though so I guess there is some hope. I am waiting for support to conclude the case but it has been quiet since last afternoon. Our entire home is dependent on Vera including the heating system (we live in Norway and today is -9gdr C outside) so I am desperate to get the system up and running again.

Does anyone know if the following procedure would work??? :

[ol][li]Reset to factory setings[/li]
[li]Upgrade the firmware to latest version[/li]
[li]Upload my last backup (both configuration and z-wave network configuration)[/li][/ol]

No advice … ?

Support has worked som more and concluded that they are not able to connect to it except through SSH. They have concluded that the problem was/is lack of available storage space even after i did uninstall DataMine before the upgrade. I have done a factory reset and the FW updated without problems (to 1.7.4001) through the Vera interface. I have attached a 8GB USB memory stick and initiated it … Would be interested in attaching a SSD. Waiting for support to advice on uploading the last backup as I do not want the same problem to surface again.

As expected this did not solve the fundamental problem which seems to be the storage or rather the way it has been utilized. SO i took Catmans advice and did a extroot with rafale77’s script ( [url=http://forum.micasaverde.com/index.php/topic,103140.0.html]http://forum.micasaverde.com/index.php/topic,103140.0.html[/url]). Great work ,worked like a charm and in 5min I had included a 120GB SSD. I hadd a little problem with the power requirement so had to change the enclossure of the SSD.

Now I am left with ghost nodes, nodes that no longer can be reached (they turn up in the morning following the heal that is run automaticaly each night and dissapear again during the day). I guess this belongs in a different thread so I will close this one.

This is perhaps motherhood but given the number of people having problems I though I should report and hopefully help some with the same problems.

I typically do a fresh backup first, before doing the factory reset. And you have to be patient during the firmware update. Sometimes it looks like it is locked up. And when restoring, again, be patient as it appears to not be doing anything. I try to budget an hour to backup, factory reset, firmware update, restore.

I was on 1.7.1030 for many months, fearing the same as you. When I got a Zooz 4 in 1 sensor and had issues, I had to update to 1.7.1040. Went smoothly the first time and adding the Zooz went well (excepting some bad parameters settings). It has been pretty stable for nearly a week after the update.

thank you Don

After doing a reset to factory settings, letting Vera upgrade to 1.7.4001 and upload my latest configuration and network backups the system behaved erratically, it was not possible to log in via the Vera portal (only local IP) and the system seemed to be out of storage (see the attachment). Support did free up some space and made the system available through the Vera Portal again. There is however still several problems of sensors/devices that have disappeared (showing up as undefined in PLEG), sensors that does not respond or send triggers to the system, ghost devices (seems only from sensors).
There is still a lot of work to get it back into decent working order and it seems I will be served by attaching external storage either in the form of a USB (one is connected now) or as a SSD and I need to study how this can be done.

Update: After 24h+ operation the system is working close to 100% again. It seems that it takes time to “reach” all nodes again which is strange since I restored a z-Wave network backup.

You probably don’t want to use a USB stick. Get an SSD. Instructions to Extroot in this thread (which is worth a read)



Thanks… @Catman. Yes USB is a short term solution. I think you forgot to attach the link to the thread… :wink:

Is this the one you refer to? [url=http://forum.micasaverde.com/index.php/topic,103140.0.html]http://forum.micasaverde.com/index.php/topic,103140.0.html[/url]

[quote=“elo, post:6, topic:205658”]Thanks… @Catman. Yes USB is a short term solution. I think you forgot to attach the link to the thread… :wink:

Is this the one you refer to? [url=http://forum.micasaverde.com/index.php/topic,103140.0.html]http://forum.micasaverde.com/index.php/topic,103140.0.html[/url][/quote]

I did, and yes. Sorry! :slight_smile: