Disable Timer

I am away and unchecked the Enable box in the Timers for my scenes that set my Thermostats and fixed the temperature at a single set point before I left. I just checked my thermostats and it seems the scenes are still running as if the timers were enabled. Am I missing something? Why didn’t this work?

Really no one?

Did you save? :slight_smile:

If I remember in the morning then I’ll try it on a test scene to see what it does if I do the same.

Yeah definitely saved once I made the change.

Just had same experience when I enabled the timers for my christmas lights last night. I had not used these scenes for a year, but when I enabled the timers and hit save, neither the On scene, nor the Off scene worked, although they worked fine when manually triggered.

Have you upgraded your firmware since you last used these scenes? I have had scenes that didnt work right after upgrades until i deleted and created new ones even though identical to the old.

Try deleting the trigger (timer) itself (not the scene, just the trigger). Save, then create a new trigger with the appropriate time.

I am sure this problem is a bug, but one could hope that the above steps could clear out the old timer and thus make things work again. Worth a try!

I use a virtual device to indicate “Vacation”, and lua code to effect the running of the scene. It is a lot easier to set the virtual device, rather than having to set/reset a bunch of timers (thus I do not see this particular bug, if it is one).

A virtual device is a great idea. Have you posted the LUA code you use anywhere for this? If not. Ar to share, would help me out a lot.

If you do a search on Virtual devices, you can find coding examples.

One useful thread is:

The specific message I am thinking of is on page two:

Hope this helps.