Device is not responding

I’ve noticed that several other members suffer from this too:
Alexa “thinks”, says “Sorry, device X is not responding”, and soon later vera does turn on\off the requested light.

Has anyone found a workaround?

My setup - VeraEdge with 18 devices mapped in alexa, no groups

Still seeing the delay irregularly. Devices sometimes respond immediately, sometimes a long delay. Doesn’t really seem to be reproducible under X circumstance. About 50% of the time I will get the “OK” confirmation from Alexa, rest of the time I get “Device not responding” and then the device responds or scene activates.

I wonder if the Vera server that is interfacing with Alexa is a bit underpowered, laggy. Am not seeing the lag when I run Vera scenes directly, only via the Alexa-Vera interface. All other Alexa functions are immediate and snappy, including 3rd party integrations like adding items to my Evernote account, etc.

Using Alexa Groups vs using Vera Scenes also doesn’t seem to make too much of a difference either, perhaps a half-beat faster using Vera scenes. The lag originates elsewhere.

I do see UI7 sending a lot of seemingly spurious alerts about Devices not responding/changing state (cams, locks, etc.). Wonder if that is gumming her up…

!!! Overall, it’s pretty cool, hope we can get the kinks ironed out. !!!

I have the same problem every time. “Sorry, device (name) is not responding”. Then it does whatever was requested.

I may have the dates wrong, but I installed the first beta and it worked correctly (no “Sorry” message) and was quick. Then when the new beta was released (Feb 1?) I installed that, and the General release on Feb 22, and have had the slow response and Sorry since then. It all crashed yesterday, but today’s Skill Update (2) installer brought me back to everything working again, but still with the slow message.

I have a fairly complex system, but I’ve tried lots of things to simplify it. I have a Harmony Skill on my Echo, and 2 controllers (Vera Plus and Vera 3)

I did submit a ticket to Vera Tech support on Feb 6. On Feb 10 I received a reply reminding me it’s beta. I followed up on Feb 22 after that install, and the May 5 reply says:

"we have addressed this case to our development team and they are working on this as we speak, but I don?t have an ETA for this.When we?ll have a resolution it will be posted on our official release notes:"

My case is #222913

My alexa skill is completely gone from my app and when I use the link in the email they sent two days ago the page says “{“message”:null}”. Perhaps the skill was pulled from the alexa store?

Update: here is the new link to download the alexa skill:,48139.0.html

I have the same problem: every time I call the Vera skill, Alexa responds after several seconds ‘Sorry, [device x]…not responding’ - and simultaneously the action will occur perfectly. After several loops of being told to uninstall and reinstall, I have just been told my internet connection is too slow and triggering an Alexa 8 second timeout…well I have broadband internet and several other smart home devices integrated with Alexa (e.g. Tado smart thermostats) which work perfectly and without material lag so the underlying issue is clearly the Vera implementation. Seems Vera Tech support are looking at the symptom rather than the cause.

I’m having this same error. Alexa tells me the device is not responding right about the same time the device responds.

Ok, it seems a lot of us are having the same problem of the delay and device not responding. I also checked with the support but didn’t get a solution till now. will anybody from Vera tell us what is happening please? the skill is not good right now. I used to give the command to Alexa and never look back, it will execute within 1 or 2 seconds, now i have to say the command and stay around 10 seconds or more to make sure it executed well. sometimes i have to repeat.

clearly the problem is the link between Alexa and Vera, as both are working fine on their own.

ditto, we need to understand the root cause of this lag and whether there is a prospect of resolving it.

I installed the updated firmware and the new plugin but that didnt help in this problem at all. I tried reinstalling the plugin and discovering the devices but that didnt help too.

Please dont tell me we have to wait till the next update to solve this.

I am inclined to believe that this is an issue with internet speed. I have two different houses both of which have their own controller and lights. The lights in my city house with super duper internet service turn on instantly when I ask Alexa. At my Mountain house with mediocre internet service the lights always take about 10 seconds to turn on and Alexa always tells me the lights are not responding.

Tonight all my devices/scenes are receiving a “device not responding” and Vera never sends any commands.

Anyone else having this issue?

Yes, something was odd last night. But all OK this morning.


I ended up installing my HA bridge again, it looks like this plug in can’t work properly over the internet… and even when it works it is taking a very long time…

I too suffer from this issue.

The very first version of the Beta, no issues and activation was instant.

Subsequent versions of this have all suffered from the same delays.

I’ll admit I don’t have the worlds greatest internet, but if it worked initially… anyway, today I helped someone set up their Echo Dots and connect them to Vera. Their internet is 5x the speed of mine in both Up/down speeds. They also have the Device not Responding problem.

I get the same thing as everyone with lights but with my Schlage Z-Wave door lock in veraplus and Amazon Dot vocal
command works without any problem ? what is the difference ?

I have abandoned the Vera Echo Skill for now and installed HA-Bridge. Voice control is now instantaneous.

I’m going to assume that the Vera skill goes like this: Echo->Amazon AWS->Vera Relay Servers->Your Vera

It’s the only way to account for the lag.

I’ve abandoned Vera, and moved to Indigo over this issue. The response has been absurd.
The Indigo plugin works quickly and perfectly.
I hope to keep Vera for a few things she does well but this, and other flakey issues with vera have been too frustrating.

I have experience the same issue a couple of times were Alexa would say device is not responding. I would normally wait a day if the devise does not start to respond I would remove the vera skill set from Alexa then reinstall the skill set. This step solves the issue for me all the time.

An alternative is Martins Alexa integration. It is rock solid and puts the Alexa control into your own hands. I’m went back to it after the recent issues and don’t plan to go back,34527.msg299341.html#msg299341

Mine works fine to turn stuff on. If you want to turn it off its only a short walk away.