Delete vera lite device

I am trying to move a couple devices from my Vera lite to a SmartThings controller and I’m unable to exclude/delete the devices using the Vera lite. When I go under the devices tab in the UI5 web interface, click the wrench and then choose to delete the device (an Aeon Labs appliance switch DSC06106, on the same power strip and within a foot of the Vera lite), after a few seconds I get a pop-up window saying the device will disappear within a minute. The device may disappear, but it re-appears within a few minutes. The device is also not excluded, meaning that I cannot get it to go into inclusion mode (flashing blue light). I can also still control the device with Vera remotes.

I’ve also tried to delete it using Luup following these instructions
The device ID is 25 in the Vera lite XML file (and in the web interface). Entering this command in Chrome:
Gives me a blank web page with “ok”.
The devices will disappear from the web interface in a few minutes, but I’m still not able to put the device in include mode, and it will reappear in the XML/web interface in a few minutes.

I thought it might just be the device that is ignoring request to exclude, but I also can’t get a Jasco/GE device to exclude/delete either.

Any help is appreciated.


This looks like a device issue:

You got the vera controller and zwave radio to exclude the device from the network but the device itself didn’t reset its homeID. If you can, try looking for the manual for that device and run a factory reset on it. On the vera, delete the device again and force delete the device or try waking it up after the factory reset. It should work.

Thanks for the reply @rafale77 I have the manuals for both devices (Aeotec and GE) but they both refer to the Controller for exclude instructions. Here’s what the Aeotec manaul says: To remove the Aeon Labs Smart Energy Switch from other controllers, please consult the operation manual for these controllers on how to remove ZWave products from an existing network. For instructions on select partner gateways, visit
The website doesn’t have information on adding/removing the switch, only how to “hack it as an on/off switch”.
The GE manual bluntly says to refer to the Z-Wave controller for inclusion/exclusion instructions.
Certainly makes me not want to buy another AEON labs (AEOTEC) product or Jasco/GE product!
Any other help is appreciated, I have four of these and they are fast approaching the herpes of Z-wave devices (fun, but now I have to live with them in my Vera Lite device list forever)

They all should give a factory reset process besides the exclusion. The fundamental issue here is that the vera thinks they are excluded after your procedure but they still report to the same homeid (defines the zwave network identity ) as the vera and therefore show up on it when they start communicating. If all your devices fail to exclude, that’s a different problem. The vera during the exclusion process is supposed to send a fram to reset the homeid of the child device and this may not be happening. In any case a factory reset of the device should work.

Success! I was able to use the SmartThings “general exclude” and then just hit the on button on the switch and it was excluded. Whew!