Creating the tar.gz file

Are there any specific requirements when creating this file? Tar compression GNU or POSIX? Pathnames relative, full, or absolute? Gzip: word size? pathnames?
I tried uploading a simple plugin and an error message was displayed.

We just call “tar czf” to place plugin files in the archive.

Like that:

tar czf node_test_plugin_edited.tgz -C node_test_plugin .

It places plugin files from the folder “node_test_plugin” to the archive, without the folder itself.

I’m working in a Windows environment and using Visual Studio Code to edit and version control files. Also using Windows apps to cretate tar and gzip files.
Also, the plugins section of the site is supposed to work no?

You can install Linux tools on Windows, also.
The “git bash”, for example, gives all the same tools we use on Linux, available from console. The “tar” is one of them.

Plugin section on Ezlogic: don’t have information.

The plugin sections should be working. Can you check it again pls

I have Windows subsystem for Linux and Ubuntu working on my PC and have used it to create the tgz file of my simple test plugin. However attempting to upload the file to my plugins on the MIOS dashboard still fails; “An error occurred while add plugin”. It would help to know what circumstances would result in this error. Does the upload do more that just upload the file and make it visible on my plugins page?

It should upload and validate the file structure , so can you send the zip file, we can check

OK, this is very limited - only to determine if I can establish communication with the transceiver.
(I’ve updated this attachment) (1.6 KB)

Can you try to set the file with extension “tar.gz” only. It does not except anything else

OK, 2 things: I used the example given above by a_kirdin to create the file with that extension and
I renamed the file to a tar.gz expension and that fails to upload as well.

So - no other suggestions? Have you taken a look at the file?

Did you also create an extension for your self on plugin settings ?. Can you please create one unique name there and use it in you plugin name like .

Yes I did. There once was a pge with the heading “Select your prefix for Edge plugins”. That’s where I entered RFXtrx. I’d found that page easily before but I can’t seem to find it anymore. Can you give me the link to that page? Shouldn’t there be a place where my selected prefix is shown and associated with my account?

Hi @tinman , you can access the setting page from here

OK thanks. As I said before, I did enter a prefix and it’s shown there:

ok I got the problem.

The company(prefix) name should be all lowercase. Also the plugin name(config.json->.id) should be lowercase.
So it is better for you to register another prefix like “tinman” and put plugin id like “rfxtrx” then it will upload.

  • plugin name
    • uses characters a-z0-9_
    • 3 to 64 characters
  • company name
    • uses characters a-z0-9_
    • 3 to 64 characters

OK, I’ll change it somehow. It’s interesting that I tried to change it to rfxtrx (all lower case) and I was given an ‘invalid’ error. So I assume it was recognized as the existing RFXtrx with only a change in case. I’d test to see if an invalid response is given for any uppercase prefix entry - but since it doesn’t appear that a prefix can be deleted I won’t try.