Creating the Arduino sensor gateway to integrate with Vera....But using a Mac...

Hey everybody! I’ve tried searching the forums but cannot seem to find any sort of guidance on this issue. Im creating the Serial Gateway using the Arduino sensors that PeteWill has created and have run into a programming issue.

Here is the link if your not familiar with it:

Ive managed to create the sensor however when I plug in the gateway to my Mac (running OS X 10.10) and run the arduino software to try and program the gateway I keep getting an error… I have uninstalled and re-installed the software plugins but that doesn’t seem to have worked. I will attach the screenshot below.

Does anybody know a workaround or the solution? (aside from buying a PC since that is out of budget)…

I flash Arduinos using a Mac frequently (I haven’t owned a Windows machine for decades) so you don’t need to go down that path to resolve the issue. It seems that you have a serial connection problem between your Mac and the Arduino - for some reason, the IDE is not able to communicate with your Arduino… First, confirm that you have selected the correct Board under the Tools menu in the Arduino IDE. If that doesn’t work, try using a different USB cable and/or Arduino.

Tried both, still no luck :-\

Any other ideas?

Sorry I don’t have a Mac so I can’t help with the issue you’re having. I just wanted to say that the credit for MySensors should definitely to go HEK, not me :slight_smile: I only made a few videos. Henrik was the mastermind the whole thing.

You also may want try posting to the forum if you don’t get many responses here. That forum is much more active and is probably the best place to get help with MySensors.

[quote=“abagadol”]Tried both, still no luck :-

Any other ideas?[/quote]
Is yours a clone? If so you’ll need a different driver. On phone atm so don’t recall but this should get you on the right track

Sent from my SM-G920V using Tapatalk

Try using Codebender.

What version of the software are you using, because your screenshot is a little different to what I see.

Ever got this solved?
For a clone nano you need to install the ftdi-driver. I had the same problem.
After succesfull install the driver shows you a device which has serial in it.
A clone UNO worked out of the box.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules