Constant: Cannot write user data - System error messages


recently my VeraEdge has been playing up and crashing quite often.

The only information provided is the:

Cannot write user data - System error messages


Running a quick filesystem size check shows this:

/# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    9.4M      7.5M      1.9M  80% /
/dev/root                 9.5M      9.5M         0 100% /rom
tmpfs                    61.9M      2.6M     59.2M   4% /tmp
/dev/mtdblock6            9.4M      7.5M      1.9M  80% /overlay
overlayfs:/overlay        9.4M      7.5M      1.9M  80% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock10          64.8M     21.7M     43.1M  33% /storage
/dev/mtdblock10          64.8M     21.7M     43.1M  33% /etc/cmh-firmware
/dev/mtdblock10          64.8M     21.7M     43.1M  33% /etc/cmh-backup
/dev/mtdblock9            8.5M      8.5M         0 100% /mios
//<IP>/vera      148.9G     37.0G    112.0G  25% /dataMine
/# du -sch *
512	1
749.5K	bin
34.0M	dataMine
0	dataMine2
0	dev
0	dmtmp
16.8M	etc
512	foo
8.7M	lib
512	log.upgrade
27.4M	mios
0	mnt
0	mnt_tmp
12.2M	overlay
du: proc/32545: No such file or directory
du: proc/32556: No such file or directory
0	proc
23.7M	rom
512	root
498.5K	sbin
93.3M	storage
0	sys
3.0M	tmp
14.2M	usr
0	var
3.1M	www
237.6M	total

I wonder if it’s because of the 1.9MB left on the ‘root’ of the fs that’s the issue?

The current firmware revision is this: 1.7.3014

I think also the filesystem layout has changed since the previous version too as I can no longer find the log files under the cmh directory.

If anyone could suggest where to begin debugging it would be very much appreciated.


Well that was fun… discovered:

then go to /var/log/cmh and all I get is:

/tmp/log# ls
Bus error

So it’s like this issue is happening every few minutes now?? :frowning:

Perhaps this is the issue??

01      09/06/17 16:04:01.518   JobHandler_LuaUPnP::GetPluginVersionOnline failed to convert 8176 <0x773b5520>
01      09/06/17 16:04:07.757   UserData::WriteUserData saved--before move File Size: 103299 save size 103299 <0x773b5520>


It seems the file system has some NVRAM errors. Have you tried to switch it off and on again to see if it recovers? Do you have logging set to be on a USB stick, and is that still working/plugged in?

The file system usage looks normal. Also those two lines from the log are not uncommon. The plugin message is about this plugin: You can try to uninstall and see what happens.

Only other thing I can think of is contact Vera support and have them look at your unit.

Cheers Rene

Hi, thanks for the reply!

Yeah I had to switch off/on many times.

I think I found the issue as the system seems to have stabilized and been up till now from yesterday.

So after checking the log file I removed the KODI, UPS and uPnP plugins. The logs still show errors regarding them so I don’t know if the plugins got 100% uninstalled or if something is cached somewhere??

For the major issue it turns out to be the EnergyPlugin that was going crazy. I removed it and the Vera seems to be stable now.

This is kind of strange as many people have had issues with it and for it to actually be an “official” plugin is really weird. Though having said that it might not be the plugin itself but the external site that communicates with for reporting.


actually the Vera seems to have popped again so it’s not the EnergyPlugin?? :frowning:

Uh more checking through log files I guess…

Try to turn off your KODI, the computer … not the plugin.

This is the log file for the Vera…

which should contain a few crashes.

I think the error message before the crash was: temp log file filesystem failure??

Second part of log file

3rd and final portion of log:

The good ol’ “WriteUserData” error. This one has been with us for years. I was hoping it would be gone by now…

That error does NOT mean it could not write user data.
It’s there because on occasion it can’t … and caused because the developer put some diagnostic print statements to see what was happening prior to it failing.

You know what the say when you ASSuME about things, such as the contents of the log file which is not meany for user consumption.

Hello all,
I’m posting on this topic as being similar with my error. If there is a better topic to move it there, please let me know!

Since couple of months I started to have this issue with my vera edge: error message “cannot write user data - system error”. Some days I had even 10 times this message. After couple of weeks, this message become “deadly” - my vera remains unresponsive.
One customer advocates concluded that a temp sensor flood the zwave chip; after couple of messages he found a second temp sensor that flooded the zwave chip. Now another advocate found a house heating thermostat “flooding the zwave network because it was reporting to Vera for multiple times every second. Because of this the z-wave chip got stuck and the unit went into a bad state.”
I’m still a newbie in this matter, however, from vera log (that I shared with customer care) I see a log writing/rotating persisting error. Am I wrong?
Thank you in advance for your feedback!

Hi toaderv,

I fear the NVRAM of your Vera is either filled up or getting bad. I would contact support to have a look.

Cheers Rene

Aside from the error showing up in the logs files, is there a way to stop it from showing up as Alerts in GUI? When I login, there are always 10 Alerts and it says the same thing 10 times. Can we filter alerts and stop it from showing in the GUI? I’m on firmware 1.7.1017.

I am not aware how to turn them off so I just ignore them since they never have been very useful.

I have been ignoring them as well but they continue to fill up my 10 alerts status on the dashboard window so it keeps me from seeing real alerts… It would be nice to have the ability to filter them out so I can pay attention to more serious alerts…

I think “can’t write user data” alert is one of the most serious you can have. If it repeats, it suggests that either something is going wrong with memory chips on your Vera, or the memory is flooded with some data and overfilled. In both cases the result may be bricking the unit.

What I did was install the Vera Alerts plug-in and VeraMate Alerts plug-in. All notifications pop up on my phone and I control which notifications I get.

I just recently started having this same problem with unable to write data. It started maybe a month ago with once a week, and now it is every few hours. They observable traits are that all of the light remain on the vera edge, ui7, latest firmware, but it is considered offline when trying to access it. Attempts to fix it have included getting rid of the static ip and choosing automatic connection (this almost seemed to help the unit heal and start up again), delete apps like ping, upnp, and anything that I noticed I wasn’t using anymore. I replaced the usb unit. I replaced the usb hub that was used because I also run the ademco app for my alarm system.

If I power on and back off, it works normally. I was already running a nightly reboot and now I have added every command that anyone documented that they got from customer service. a few days ago, I wasn’t able to enable remote access which I was trying to do so that I could find the unit ssh password to look at the logs. I took a backup, reset the unit, and restored the unit. This seemed to make it work for at least a day or two. I was so confident that I made a few changes attempting to get my sonos working and now it is worse. I believe I have deleted every thing that I had changed or installed.

What surprises me is that I believe the unit is still running, the internet light still blinks, and I still get some prowl messages as if it were running. I just can’t connect to it either by ip or home.getvera. Until I reboot.

I thought I would send this out to see if anyone made any undocumented discoveries. I am going overseas in a couple of weeks and it is pretty imperative that this is working. I plan to invoke a customer service tickets, but I don’t have a lot of hope there. Any latest thoughts would be appreciated.

As an aside, if a new unit is required, would my backup go cleaning to a new edge? what about a new veraplus? I know I would have to get another license for pleg but I am always happy to buy Richard another beer.

My system isn’t that complicated. blue iris for some cameras, alarm, motion, and some switches. Any ideas?

Call Customer support if you are having problems.