Concierge Home or device don't show in google home

Hi, I am trying to setup a Raspberry Pi to run the concierge server. My apologies if it appears I have no idea, unfortunately I don’t, I’ve never played with Linux before.

I have the server working on the pi, it shows the vera device as well as the google home/cast devices on my network. If I do a connectivity test it says ‘successful bi-directional connectivity’.

My problem is that the Google Home app doesn’t show the concierge home control in the devices. It says successfully linked to my google account, but nothing appears and of course nothing works.

Under my veraconcierge account page, it doesn’t show my vera.

Hopefully someone can point me in the right direction.


on concierge sever do u see ur Vera with a local ip and if u click custom settings do u see a list of your devices

Yes, I can see everything listed correctly there.

I assume connectivity tests have passed …
Unlink Vera Concierge from your Google Home and Re-link it.

I have done that several times also, with no luck.

I am going to try and set it up temporarily on my Intel compute stick under windows to see if it is raspberry setup issue.

Try using a different Google account and see if it works … Just a test the remove all Google association and re associate

I have tried resetting, unlinking etc. I don’t have another google account to try. I have attached a couple of screen shots.

I am running a veraplus if that makes any difference.


if you are running it locally which i assume, i think ur firewall is blocking it try disabling the firewall and see it picks it up

I have turned off windows firewall, and added the ports required pointed to the concierge servers ip address in the router. I also inititally added the ports to windows firewall, but then turned it off to be sure.

Should the port forwarding in the router be pointed at the concierge server or the veraplus?

it should work i never had to do that and im running a Pfsense.

The router does NOT need any port forwarding … Port Forwarding is in general a security vulnerability … it allows you to connect to a port on a machine in your house from the INTERNET. In general this can be exploited to bypass your routers settings …
Vera concierge does not need any special ROUTER changes … unless you have manually changed some default router settings … i.e. restricting UDP or limiting multicasting. If you did this your Google Home speakers would not work properly.

I always RECOMMEND AGAINST doing any port forwarding.
Does your unit pass the connectivity test ? If not you probably have a FIREWALL issue on the PC/Computer running the concierge server.

Yes, it passes connectivity tests, it just doesnt show under linked veras on my account page nor in google home. As i said, i have disabled the firewall alltogether on the concierge server pc. And now have since removed any port forwarding as you said it is not required. my google home home works fine, I can use the chromecast with it, I have linked my samsung robot vacuum cleaner to it and it works also, it is just concierge that won’t show up in the device listing.

My sincerest apologies, the one thing I didn’t try was running on google chrome…

Everything is working fine now.

Thankyou all very much for the suggestions and help.

Cheers, Brent

What browser/OS were you running on ?

It’s running on an Intel Compute Stick with 32bit windows 10. I had to change the server program in the jar file to 32bit version. I was trying to run it on internet explorer. It appears that IE does not show the complete server page. When I changed to chrome, another update cloud info button appeared at the bottom of the server page, as soon as I clicked that it came to life