Ceiling fan control

I have two Hunter ceiling fans in the great room on one circuit controlled by a GE JA12730. Also have one fan in the bedroom run by another JA12730. In the bedroom, the iOS slider works great, adjusting the speed smoothly. But in the great room, 67% is just spinning slowly and anything above 68% is like full speed. How can I get the great room to be more adjustable?

Do you have the fan speed at full on the fan motor?

Yes, in both rooms.

Assuming that the fans are not different models, it sounds like you might have a bad switch.

Also, be aware that even though your slider offers 100 speed levels, there are only three speed settings available on this switch. Approximately, Low < 33, Medium > 33, High > 66.

Am I right in thinking that you have both fans in the great room on the same controller in parallel? If so this would explain the behaviour that you are seeing.
As a three speed device the controller is switching in 2 capacitors ( one for low and one for medium speed) that need to be matched to the fan motor. At full speed there is no capacitor and so both fans are running normally.
I’d suggest putting in a second fan controller, and use logic in the Vera to have them “follow” each other.
If you don’t want/need a second wall plate, the second controller could be installed out of sight and follow the first one.

@Weeves - Great catch!

How do the LEDs look on the switch itself to indicate speed ?

reason I ask is because I have a condo we rent with a minisplit and a ceiling fan. I can control the minisplit with a Remotec Z-Wave ZXT-120, but I also wanted to control the fan remotely to help the A/C do its job.

I need something that is sufficiently self-explanatory that I can have complete strangers use it without freaking out.


You can see the GE 12730 Z-Wave Smart Fan Control here.

The single small LED(lower right corner) is a locator that can indicate On/Off, it does not indicate speed.

I read the questions / answers and saw this :
In the factory default mode the Blue LEDs are set blink differently for each speed. I have turned the LEDs off through the manual settings. Here is a link to the User manual.

interesting. I might need to try it, then! Now, if only they had a dual-dimmer for lights and fan…


Let try it