Can't View Site on Mobile (Android)

Is anyone else having problems viewing this site on their phone? A few days ago, I suddenly started getting blank pages, through the Discourse app for Android, and in Brave, Firefox, and Chrome. Oddly, it works on my tablet, but not my phone. No problems on any desktop. I’ve tried disabling all the protective features on both browsers, and still no joy. Cleared private data; no joy. Discourse app and browsers are up to date. I’m stumped.

@Sorin, I note that the SSL certificate for this site is showing expired (as of 12/18/2019)… maybe that?

On my side is serving the mobile versions both on Safari and Chrome on iOS.
Let me check out the certificage thingy.

1 Like

As you are a developer, I’m gonna be frank and tell you I have to dig this more.
I checked everything and what is mind blowing is that incognito/private mode shows the right cert. Normal mode shows a bad cert but still works.
Curl gets the right cert. Openssl the same.


Very strange, right? And why is my phone goofing up and not my tablet? And why just a few days ago, and not starting 12/18, if the certificate really is the cause?

So bizarre… makes we wonder if a CA cert somewhere has expired and not been replaced.

And I see the same behavior on Opera too. I bet this is some browser cache.
Midori is correct.

Seamonkey is the same.

Well if it’s cached, then its cache someplace that all the usual controls don’t get to, because I’ve run complete flushes of “private data” on both Chrome and Brave. Is there a CDN in the mix here?

Nope, no cdn, plus this should not matter. I will try to replace the cert with something else.

I just went into my phone and blasted Chrome… stopped the app, cleared the cache, then down and removed all stored data, site stores, etc., things that apparently the regular on-menu clear of private data doesn’t.

I can now see the site contents in Chrome. Working on Brave…

EDIT: OK, I was a little more deliberate with Brave. Went in to Settings > Apps, force-stopped the app, cleared cache. Then tried to load the community site again, still blank.

Back to Settings > Apps > Brave on the phone, force stop again, clear cache again, then into Manage Storage… “Clear All Data”. Back out and open Brave, clear through the new install/welcome stuff, and there it is, the community site displays! And correct certificate.

OK. So apparently there’s some deep caching that goes beyond what “Clear Private Data” normally reaches, and even the usually-aggressive “Clear Cache” on the app doesn’t get. WTF.

Edit 2: I also had to do the same on the Discourse app itself. I could go in to either browser directly and see the site, but if I launched the site from the Discourse app, I got the same blank page. After force stopping the app, clearing cache, and clearing all data, I was able to re-register the site with app, re-enter my credentials, and see the site.

If that’s all certificate-related, I hope it goes better on the next renewal. I use LE certs a lot myself, and never have trouble like this, so hopefully it’s just teething pains–it looks like you transitioned from GoDaddy to LE? (good move)


Le is good on everything but shops or sites that require payments. For those ones it is better to have OV/EV SSL certs, not mandatory though.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules