Can't save TTS settings

Since upgrading my VeraPlus to 7.31, I am unable to change my Sonos devices TTS settings. Prior to the upgrade, I was using rigpapa’s Sonos 1.4 app configured for ResponsiveVoice. All was working well.

When ResponsiveVoice stopped working earlier this week, I upgraded to 7.31 hoping that might resolve the problem (I was not aware at the time that ResponsiveVoice had “died”).

After the upgrade, I started getting system error messages about a couple devices failing to load their implementation files. The device numbers were not ones I recognized. Some kind of media server??? The implementation file name included “RINCON” so it sounded to me like something related to Sonos. I contacted Vera Support. They deleted the devices and the system error messages disappeared.

I next tried to change the ResponsiveVoice setting to something else (e.g., Mary, Google, Microsoft, etc.), but clicking on my Sonos device’s settings Save button did nothing. I tried upgrading the app from 1.4 to 1.5, but was still unable to save any settings changes.

Still hoping to get TTS working again (with Azure), I upgraded from 1.5 to the app’s development branch. The upgrade appears to have been successful. I now have a parent device for my original Sonos devices and Azure is a selectable setting. However, when I try to save the settings change (e.g., click on Save) nothing happens.

Does anyone have any thoughts how to resolve the inability to save Sonos TTS settings? Thanks.

I believe you need to upgrade to the 2.0 beta to use Azure

Thanks, I have. Problem still remains…

Oh whoops, glossed over that part!

Have made some progress. Was finally able to update the parent Sonos device settings while waiting 10-15 minutes after clicking on the TTS save settings button. TTS not working yet. Trying to determine why. Have set log settings on, but not sure how to access the log.

What build of Sonos 2.0 beta did you download and install? Only from “Sonos Plugin version 2.0develop-20052.1358” forward (as shown on the bottom of the master Sonos System’s SETTINGS screen) did the “Wont save settings” issue disappear.

Hope this feedback helps.

Thanks for your response. I have updated from Sonos Plugin version 2.0develop-20052.1532 to Sonos Plugin version 2.0develop-20052.1900.

I’ve been able to update the plugin settings by waiting 5-10 minutes after clicking on save settings button. I still haven’t been able to get TTS to work.

I’ve enabled Debug Logs for Plugin and TTS Engine. How can I view the logs?


1 Like

In the log I see “Access denied due to invalid subscription key or wrong API endpoint.”

Can someone provide instructions how to create an Azure Subscription Key? I’ve been trying to use the Subscription ID I received when signing up for Azure, but apparently Subscription ID and Subscription Key are not the same thing???

You need to create a cognitive services resource. That’s where the key comes from. Read the instructions for that the end of this post: Installing Sonos Plugin 2.0 (development/pre-release) for Azure TTS access - Sonos - Ezlo Community

Thanks rigpapa. I was able to create the key and add it to the Sonos master device settings.

New problem - Now all my Sonos child devices are reporting “Can’t detect device.”

Not sure what to try next… :slightly_frowning_face:

My first guess is that you might have missed uploading one of the plugin’s files, so something it needs is either missing or still sitting on the old version from the prior plugin. Can you go back to these installation instructions and re-run steps 4-10 (only), then run step 14 last.

Many thanks rigpapa!!! That resolved my problem and TTS is now working. :slight_smile:

Forgot to mention…

After the plugin files were correctly installed, I also had to go to User Security Settings and “Enable potentially unsafe lua code, like wget and RunLua.”

Yes, the plugin will issue warnings to the log file is UnsafeLua is not on but you attempt to use TTS.