Can't get Vera3 in switch mode

My new Vera 3 is behind a modem/router with IP range 192.168.2…
The Vera doesn’t go automaticaly in switch mode.
I don’t get wireless ip numbers in the same range as my modem/router
Manual setup doesn’t solve the problem.
Does anybody know what the right settings are?

Unfortunately, Vera 3’s switch mode will be on it’s own separate subnet. That subnet would be in the range of 192.168.81.* I believe.

  • Garrett

I’ve encountered the same problem and must say that’s not how a switch typically works. The documentation online lists the option for switch mode but I don’t get it on mine.

No help here unfortunately, but some advice. Be careful of the options in the advanced link. I tried doing much the same as I think you want to do by playing with the bridge options and can no longer talk to my device. :frowning: I started a thread with this title if you have any ideas:

Vera 3 Network or Factory reset?


edit: It looks like my Vera 3 reset to a default condition and I was able to restore off the backup. I’m not sure if it did this itself when it couldn’t connect to the network or if hitting the reset button helped.

I remember reading a post from one of the MCV staff that mentioned that they may have a driver/kernel issue with the V3 that stops this from working correctly at the moment… cant find the post now!

I’d like to see this issue fixed also!

This is the answer of the mios support group:

Hi Cees,

Sorry for the late reply but I have discussed it with our developer team and Vera 3 does not support switch and bridge mode like the Vera 2 did. It may be included in the next firmware releases but at this moment there is no way you can put Vera in switch mode. Please let me know if you have any other questions.

Thank You!

Wow, what a disappointment. I just got my new Vera 3 today and was trying to get it established as an AP for my wireless network before starting the zwave enrollment. I figured it was just the typical operator error and some forum-wisdom would set me straight. Sounds like I’m out of luck for now. I can get it to act as a switch, but only if the Vera3 is not connected to the internet itself. I even tried connecting my LAN into the LAN side to get the switching function, then routing from one of the other LAN ports to the Vera’s WAN port. That made it very confused! ???

I guess I’ll just turn off wifi and not use it as a switch.

If I had known I would have saved the extra and bought a VeraLite. I’m a little tempted to pack it back up and return it as I could have bought a separate AP for the price difference.

I don’t get this “can’t use it as a switch” thing. Maybe all it’s missing is a default route. What’s the problem exactly?

I’m sure they’ll get it work soon! Allegedly it’s an issue with the openwrt side of things at the moment, and needs some development there to get it to work.

The key issue is that you can’t get it to be a switch on an existing network. It will act as a switch on a different network (the default being 192.168.81.x). But if you want to use it as a wireless access point for your current network (say 192.168.0.x) it would need to have that address on the LAN side. If I set it up to work that way, the VERA can’t see the internet even though the switch is providing access to the LAN to clients (both wired and wireless.)

If I set it up to work that way, the VERA can't see the internet...

That’s a textbook description of a system missing a default route.

Describe how you’re setting the LAN ip address to 192.168.0.x. Are you manually setting the address in the UI5 interface? If the latter then you’ll notice the box for “gateway” is conspicuously missing; when you configure an IP address on a host you need to point it at a router to see out of its local subnet and it looks like you can’t do this on V3 from the UI. I guess the MCV scr*w-up was to forget that, unless there’s another issue under the hood.

You can configure the default route on LuCI interface (Net & wifi → advanced configuration…), if you want though. I can see two ways: either from the interface config. for the Lan inteface (Network->intefaces->Lan (edit) put your internet router in the IPv4 gateway box) - or you can add a static route under the network->routes tab.

Another option would be to enable a DHCP client on the LAN interface. Go to LuCi, then Network->Interfaces->Lan(edit) and change the protocol drop-down from Static to DHCP. Disadvantage there is that your Vera website might change IP address on you if the lease expires (probably won’t happen very often.)

Just to remind you MCV have decided in their wisdom that LuCI “doesn’t work” and won’t give you any support if you change anything with it.

Alternatively you can hack through the OpenWRT documentation to set the same options from a shell. I guess the same MCV caveat applies there too.

Your third option is to wait until MCV wakes up and gets their act together. Could be while though.

I’m tracking all this, as I’d very much like to get my Vera 3 acting as a “WAP” on my established home network – where my existing router still assigns all DHCP addresses, provided firewall protection, etc.

Related thread persuing same:,9264.msg61129.html#msg61129


Has there been any updates from this regard? It seems that if I plug the WAN port into my existing router (D-Link DIR-655), then the LAN ports and WLAN are on a different subnet ( I would like to go all-wired, but having a double NAT is not acceptable.

My hope was to use the Vera3 as a layer 2 switch and eliminate a 5-port switch that’s currently in my wiring closet. Will this ever be feasible?

I posted a reply to your same question over here.