Can't get into my system

I was gone all last week on a business trip and thought it odd I didn’t receive any alerts from the system (normally get door lock notifications). I tried to access my VeraPlus unit using a web browser and could not get in. So I reset the box by pulling power, waiting a few seconds, and reconnecting power. A few minutes later I received 12 text messages and about 50 emails of notifications over the last week - nice to know the unit buffers notifications, but since they are all out of date, it is a waste.

But, I still couldn’t get into my unit directly. I then went to and tried to login. My credentials did not work. I gave up and clicked the password reset link and entered my email on the next page. It was not recognized. I entered my username and that apparently worked. It worked so well, that over the next 5 minutes, I received over 130 password reset emails. I only opened a couple, but the links they provided did not reset my password.

I can’t access my unit, I can’t access my account, and I have submitted a ticket to support. Why my unit suddenly stopped working baffles me, but a reset should have fixed it.

I realize there’s nothing I can do at this point, but I thought I would share my experience in case anyone else is going through the same thing.

Having same problem here, Except im not getting any emails and username doesnt work either.

I too have the same problem