Can't enter pin code notifications for Schlage lock

My Vera 3 won’t accept PIN code notifications/triggers for my Schlage lock.

I can select the “A Pin Code is Entered” notification, name it, enter a pin index number and save it. But then its description reads “undefined” in the notification list. In the trigger list name, description and last run are all labeled as “undefined”. The scene label is the name I gave it, e.g. “Someone enters”.

I’ve tried entering the pin index as, for example, 4, 04, #4, * and as the pin itself. Same result.

Otherwise, Vera and the Schlage deadbolt are working fine together. I can set a notification and a trigger for “A door is opened or closed” and “Bad PIN entered”, and everything works as it should. No problem setting pin numbers either.

Am I missing something? Or do you think this is a bug in UI5? It doesn’t seem like there’s any problem with the lock. The error shows up in Vera immediately upon entering it – no time for it to talk to the lock.

There is another thread with someone who appears to have similar issues, (,5435.60.html).

I am running UI5 (1.5.236) with a Schlage lockset. I tried out setting up a notification and a scene trigger using a PIN code and had no problems. So, the problem does not seem inherent to UI5 but rather conditional on some configuration or combination which unfortunately means it is not going to be easy to find.

Thanks for the link, Stappy. I tried the exclude-reset-include cycle several times, and I’m still getting the same result. Notifications for a PIN entry still show up as “undefined”.

I can do pretty much anything else with the lock. Add pins or other notifications, for example.

One thing I’ve noticed, though, is that my firmware shows as 1.5.215 and Vera says it’s up to date. But you have what looks like a later version. It’s an avenue to pursue, anyway.

I have a Vera2 and I think another thread mentioned that the latest firmware was differnt for the 2 and 3. However, my Vera said it was up to date as well and I had to go fetch it from cp.mios.

Good luck

Good call. My firmware also needed updating via It did something, because now the default name for the lock is _Schlage Deadbolt rather than a generic name. I’m still seeing the “undefined” problem with pin code notification, though.

But in the morning I’ll do another complete exclude/rest/include cycle.

I’m making some progress. I haven’t done the exclude/reset/include cycle yet. But I did enter some “pin code is entered” notifications after the firmware update (to 1.5.232) and I’m getting some response out of them. The notifications still show the name/description/last run as “undefined”. But when I enter the pin codes, I’m intermittently getting the notifications via email.

It seems as if all the notifications are intermittent – sometimes I get them, sometimes not, and sometimes the emails arrive after many minutes (>30 in one case). There’s also inconsistency in how the “last run” field is populated on the trigger page – sometimes a notification registers, sometimes it doesn’t.

I also cannot get any log information – the device specific and user specific alert pages either have no content or (seemingly randomly) say “No records”.

One other glitch: on the lock setting tab, I can’t enter a value for “Fire warning event when battery is below”.

It’s possible the core issue might be a browser problem, but I’ve seen it so far on the most recent versions of Chrome, Safari and Firefox running under OS X 10.7 and on a Linux machine running an older version of Firefox.

I’m going to do a full exclude/reset/include cycle, and also check the USB stick I put in to see if I can find any logs.

I’m going to start a new thread in the general section – the problem does not seem to be specific to the lock. It’s some kind of read/write, I think.

Edit: it’s moved into the Getting Started section – another user was having the same problem and mcv responded: