Cant add generic camera using Mios app

I have tested adding generic RTSP cameras on a few android devices using the new Mios app on an Ezlo Plus controller, I wanted to migrate from Vera Edge.

The new Mios app crashes on every android device I could find. I just try to add generic camera and I get error “app closed!” dont see that very often. Two sony phones, a samsung tablet and a pixel 6. all just “app Closed” when adding a generic camera for the add wizard.

Support said use the Vera Mobile app? OK so forget the Mios app for my purposes it just doesnt work or is it just me?

Thankfully I added it using the Vera mobile app, great!

NOW that camera is there but doesnt work just circles. I have the correct URL that works fine in VNC and I can view it on my Roku TV with the IPcamviewer app no problem my camera is working.
I try to edit the url or password or anything and the camera settings can NOT be edited once created. They just dont save.

The only way to make any changes to the RTSP URL once created, is delete the camera and start over.

Anyone else have the issue of unable to edit and must use Vera Mobile not Mios?

I’ve never tried this, adding 3rd party cams directly onto an Ezlo hub via rtsp streams, so cant comment.

It did work in the past using mjpeg streams and the old Vera firmware hubs.

I have however tried the Ezlo “Vidoo” nvr cam software before and added third party cams to that, which in turn then get integrated into the Ezlo ecosystem.

You need a separate box however to run the Vidoo software as it doesnt run on the Ezlo controller itself.

I am using a beta build of the Android Mios app and there is the option to add a Generic IP camera.

I assume this is the same with the Play store version?

Or are you using iOS?

I can confirm I had the same issue when using the Vera and Mios Android apps. Changes were not saved.

I just tried adding a new Generic IP camera using the Android Mios app, the app crashed when I hit Save.

After relaunching the app the camera had been added anyways however.

Didnt have that same problem when using the Vera mobile app instead.

I didnt notice a camera being added despite the crashing. I got it added per se but it is not functional.

I am using Play store version running on a couple different Sony Compact Android Lineage OS 18 I believe. I even tried on a new Pixel stock android still same results.