Cant add device issue

Hello, just trying to install a new lightwave Rf wall switch into my Vera Plus (1.7.4970) firmware, I already have other rf devices working with out issues
I go into my RFX controller create new device all seems to be ok, but the new device does not appear in the UI

I have also just updated the RFX plugin to 1.96 but it still doesnt appear

Any ideas?


I assume you selected the Switch Light device type. Can you tell me what you entered for the ID and unit code?

Hello, thanks for the reply, Unit code was 1 and the ID I just selected a random number called the device Garage, have tried 4 attempts but still no luck all with same ID but different random ID’s, thanks
Oh and yes Switch Light was selected

I had to do this a couple of years ago but I thought this would have been fixed by now, thanks

The ID and unit code must match that of the switch. I’ve not used a Lightwave device but I suspect it may have a way to set the unit code but not the ID. Did the switch come with a remote control and does it work to operate the switch? You may have to connect your RFXtrx to your computer and then run RFXmngr to discover what ID is being transmitted by the remote. The RFXmngr program is available from as is the RFXtrx user guide which has information on how to use RFXmngr.

Thanks, but I don’t have a remote with it :frowning: maybe I should try to downgrade the firmware in my Vera

seems strange that no one else has this issue, perhaps they have the remote

I don’t think that dowgrading the firmware will help. If you don’t have a remote I don’t know how you can discover the unit’s ID value. Do you have a model number of the switch? If I can find technical info online perhaps it will help.

Its a 13A 2 Gang Socket Model No LW270 Lightwave RF

OK, the device has a pairing mode so you don’t really need to know a specific ID. Any decimal ID number should work. When you enter a name, an ID number, and a unit code and then click create, do you see a message indicating that ‘Vera will reload to validate the changes…’?

yes it does say that but it doesnt appear to reload and no new device is visibale in either the UI or managed devices in RFX, thanks

OK if it is not reloading there may some kind of problem. Do you have other devices controlled by the RFXtrx? Do they appear to respond to commands?
You can force a reload using your browser: Open a new browser tab and enter http://your_RFXtrx_IP_address:3480/data_request?id=reload
If your devices appear to work and the reload doesn’t cause the newly created device to appear in the Devices tab in Vera (in the No Room area) you may have to enable debugging and view the Vera log.

ok thank you

Oh well took a chance and rolled back to earlier firmware, as previous post, worked ok added devices no problem, put some spares as well :wink: sorted
Thanks anyway

1 Like

Obviously I’m running the latest version of the plugin 1.96. I’ve created a Lightwave RF device without any problems. An earlier version of the plugin should make no difference with this type of device. Without more information I cannot investigate further.

Hello Tinman, thanks for your replies, for what it’s worth I dont think the problem is with your plugin, when I rolled back the firmware in my vera plus everything worked fine, then I just updated my vera plus to the latest firmware, thanks