Can't access port 3480 on Vera Plus

Hi - when I first bought my Vera Plus I was able to send Http requests to it on port 3480. One morning I woke up to “ip address refused to connect”, and I have not been able to access Vera Plus on port 3480 any more. I can’t think of anything I changed on my side. I tried a factory reset, but that did not fix the issue. What could be the problem?

Did you verify (on your router) that Vera had the same IP address as before?

Yes, it was set to a static IP address and I could access it at that address. Everything else worked from the main interface, I just couldn’t access 3480.

if you go to Vera’s IP address you use for the http requests in your browser (without the :3480 etc part) does it show the dashboard or do you get like a ‘page not found’ or ‘server not responding’ type error? If so, it seems Vera’s IP address may have changed. Use a netscan type tool on one of your other devices and you should be able to find the new IP address (use the MAC address on the bottom of Vera for identification)

I have Vera Plus set to a static IP address 192.168.0.10. If I navigate my browser to this address I can see the UI7 interface and control everything normally. If I navigate to 192.168.0.10:3480, I get “this site can’t be reached” “site refused to connect” error.

When you log into the web dashboard, are you prompted for credentials? If so, the ‘Protect my vera’ setting may have accidentally switched itself on. You can switch it off in the settings (unfortunately the upgrade to the new beta just failed on my Vera 3 and it’s down until support fixes it and I have no access to look where exactly it is)

If no credentials were prompted for, it sounds like the internal webserver (lighttp) has an issue. If you are comfortable with SSH and Unix, you can SSH into Vera and check the logs for any issues. Otherwise I’d suggest to contact support@getvera.com and enable access so they can remote in and take a look at it for you.

I am prompted for credentials - I see a setting in UI7 “Users & Account Info -> Unit settings -> Secure Vera”, but it is already off. Is that the setting you made reference to?

Also, I am comfortable SSHing into Vera to check the logs. Which log file is it that I want to check?

That’s the setting and if it is off and you go directly to Vera (without going through home.getvera.com) you should not be prompted for credentials if you just go to the dashboard. If you do, it looks like that setting may be set to on but not showing such. I’d suggest emailing support@getvera.com and enabling remote access so they can fix it.

I’m not at home so I can’t SSH into a Vera and check log locations.

Edit I see now you were asking if I was prompted for credentials when accessing it locally, and the answer is no. I mistakenly thought you meant when I logged in home.vera.com. When I hit 192.168.0.10 I am not prompted for credentials.

Also… I definitely think there is a problem in the logs. Every time I hit port 3480 I get this in the log:

2016-11-23 11:03:55 - LuaUPnP Terminated with Exit Code: 245

2016-11-23 11:03:55 - LuaUPnP crash

Nothing precedes it - meaning when I hit port 3480 those are the first two lines in the log.

Another thing I see pop up in the logs (not when I hit port 3480 though) is:
LuaInterface::LoadCode: [string “local file = io.open(”/www/devlist.txt", “w”)…"]:19: ‘=’ expected near ‘/’ <0x743c7520>
01 11/23/16 11:11:24.088 JobHandler_LuaUPnP::RunLua failed: local file = io.open("/www/devlist.txt", “w”)

Any ideas?

Did you make any changes to LUA code, eg in scenes, recently? As it looks like something causes the LUUP parser to crash.

It could also be something got corrupted, but again, that would be something support can fix. Especially if you provide them with the log snippets above to give them a place to start.

I have not really made changes to Lua recently. I’m leaning towards corruption in a file based on the log message. I will contact support. Thanks so much for all your help - I really appreciate it. I will update this thread when I resolve the issue with support.

FYI - I have seen the same activity on my VeraPlus today…

IP is set static, and yet it changed - I could not reach it through IP address directly, went through getvera and noticed that my IP was +1 address different…

All day today I have been getting LuaUPNP Terminated with Exit Code: 137 and VeraPlus has been unstable…

Only thing I have done lately is install the MySelector app… I uninstalled a few hours ago but am still getting the error… Will try restoring a backup to see if that resolves the issue…

Any word from support on this?

I have been in contact with support, but its been really slow to get a response (perhaps due to the holidays). I have not gotten a resolution yet, but I will report back when I do.

Also, does anyone know where a list of exit codes and their meaning can be found? I noticed I am getting a different code than you, art2u.

Customer support has been unhelpful - their responses are not to the point at all. So while waiting for them to respond I performed a factory reset. The http server does not work even after a complete wipe. I hit the reset button 6 times rapidly, then waited 5 minutes for the lights to come back on. At this point I found vera again on the network (it was a new ip address) and navigated to it to verify it was blank (it was). I then hit port 3480 and got the same error. I am guessing its a hardware issue at this point. Does that sound right?

Since the dashboard works, I don’t believe this to be a hardware issue perse. It sounds more like a corrupt file related to lighttp or the LUUP engine causing this. One that a factory reset did not address. Who in support did you talk to (if I may ask) as so far they’ve been pretty helpful for me when I had to call on them. I know right now their response time is slow but most of them, like us, are still in a tryptophan induced semi-coma. :slight_smile: Having been in IT for decades, I’m pretty sure that same team is also addressing the Alexa beta issues so they have a way higher than normal work load. Leading to those slower response times.

I understand the slow response times, and I didn’t mean to throw the support team under the bus. I have contacted their tech support before and they have been quick to respond and helpful. Since you asked who I spoke to I will say I have received e-mail responses from Christina and Tudor. One of the responses simply linked me to the documentation for HTTP requests, after I clearly stated that I had it working but now it stopped working and I also included logs of the error :frowning: I’ll give them some time, and update this thread when we figure it out.

I know support is always very busy, so I have been trying to resolve on my own… I have restored from backup 3 times… The last time seems to have stuck though, as my system is responding again and I am not seeing the repeated Lua shutdowns…

Not sure what the exit codes are and agree it would be nice to have a list to try and understand what is going on…

I figure I will try to leave the current setup as is until after the holidays and then take another crack at adding devices, scenes, etc…

Let me know what you hear from support - thanks

Tech support has basically just said “disable and re-enable remote access” for the 3rd time (it was enabled in the first place) and have not really gotten to the heart of the issue yet.

However, http requests randomly started working again. I have no idea what happened, as far as I know nothing changed. I still can’t navigate to port 3480 in a browser, but sending the URL requests works.