Cannot delete corrupted Ezlo scenes / Meshbot rules

I have four scenes / Meshbot rules that seem to have gotten corrupted and I cannot edit them and I cannot delete them, which is what I want to do now. I have tried in the Vera mobile app to delete them, in the Ezlogic web GUI and even in the Online API Tool and I cannot get rid of them at all.

Doing a hub.scene.list command in the API Tool I can see they are still in the list of results, this one for example:

However when I try to delete it I get this error: “The scene with this id does not exist”

Does anyone know how to fix this issue ???

Thanks

Hi there!

I will check if something can be done in order to force the removal of those for now while we investigate a little deeper.

I would like to know if perhaps they got corrupted after making some changes or a firmware upgrade or if you can pinpoint what happened prior to them going bad it would be awesome!

Hi Leonardo

Three of them had LUA scripts on their actions. I originally created them in the Vera mobile app when you first released lua scripting on the Ezlo hubs.

Then later they stopped working likely due to changes in the development / architecture etc.

They then got corrupted and I could no longer edit or delete them.

Note for other users Lua scripts are now operational again in Meshbot rules.

And the fourth rule I am having problems with, I’m not sure what happened it was just a regular rule for a lights schedule that is now corrupted.

The names of the problem rules are as follows and they can a be deleted if you can do it.

Globe Lamp Toggle via Lua Code
Globe Lamp On via Lua Code
Globe Lamp Off via Lua Code
Schedule Lounge Lamps ON

If you need access to my Vera user account, just DM me a message.

Thanks

These scenes / rules are on the Ezlo Plus controller the one with the serial number 90000400.

There are 5 controllers on my account in total.

Got it! that’s good info, at the moment I would need you to enable remote access on that controller and that would be it. (Keep in mind that when you tap the toggle button it will not stay green and visually it will revert back but it will be actually enabled.)

Let me know when that’s done to proceed.

That button seems to work OK in the Android Vera mobile app, its turned ON and has remained turned ON and green.

Oh ok, thanks!

The scenes were removed, please take a look and let me know if you see the same on your end just to confirm.

I’ll remain attentive.

How did you remove the scenes? Is it something I can do myself somehow if this happens again?

I have checked and those four rules have now been removed.

Thanks

Well… yes, you can use the following script made by one of my colleagues but I modified it in order to delete scenes.

Here it is: remove_scenes.zip (950 Bytes)

You can either SCP that file into your eZLO and then follow the commented instructions in the file or perhaps just create a file in your eZLO through SSH and then just copy and paste the script.

If you have questions about it let me know!

Great thank you I will keep that handy.

Alexey is also looking in to this issue now, I just sent him the storage.bin file he asked for off the controller.

Just tried to use the script to remove a scene but I am seeing this, any ideas?

I am using the _id of the Scene obtained from the Online API Tool.

Thanks

image

That’s weird… it does actually have the reserved word there.

image

Would you mind enabling remote access once more?

@Leonardo_Soto

OK I enabled it.

Most of the scenes left on this controller I cannot edit or delete. And these were not using LUA scripts in their actions either.

I am moving to a new Ezlo Plus hub as this old one seems to have issues now

The only difference is that at the end of the code you were missing an “echo” after I typed it in, it started working, I left the script there if you want to check it out and the scene you were trying to remove is no longer there.

Great thank you again !

Leonardo the script is now working and deleting scenes thanks.

Did you update the script posted into this forum thread also?

If other users want to download and use it etc.

Hi there!

The script I uploaded is ok, perhaps when you copied and pasted it the last reserved word was missing, but I actually downloaded the one uploaded here and it was ok.

If you have more problems with scenes or so let me know.

1 Like

@Leonardo_Soto @Oscar.Morales

I am trying to use this script again today, but on a new Ezlo hub and I am getting the same error as before.

I downloaded the script again from this forum post and placed it in to the /tmp dir on the hub etc.

Not sure why this is happening?

Are you able to take a look for me again please ?

Thanks

Hi there!

Would you mind letting me know the serial number? also, enable remote access.
I will check!

Done

This is the corrupted scene I need to delete

sh remove_scenes.sh 1f09533123e4312d9310c2e

Name is “Globe Big Lamp Toggle”

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules