Cannot control any devices via Alexa

As of yesterday all Alexa control of Vera devices stopped working. No device on either Vera hub can be controlled so it seems the Alexa integration is completely broken.

Please fix ASAP.

This just happened to me! All devices became unresponsive. I deleted the devices in Alexa, disabled the skill, re enabled, linked up fine. Can choose devices to add but when Alexa goes to discover then it says it can’t find any. Very frustrating.

Support have been made aware of the problem.

Yes thanks. I just saw that here in the forum.

Issues with AWS apparently they are looking into it now.

Same experience here. Failure occurred between 6am CDT 23 Oct 2023 and 1pm CDT. Initially, I disabled skill and then linked account: Alexa knew of the Vera controlled device but could not operated it. Hue devices continued to work. Then disabled the Vera skill in the Alexa app, deleted all Vera devices from Alexa app, linked the Vera skill, selected all Vera devices during the linking process. When the Alexa app tried to digest the Vera devices, it failed and when back to the iPad desktop. Various combination of disable & linking fail.
Best regards to all.

Mine just reconnected. Thanks! You don’t know how used to something you become until it breaks and you can’t just take it into the garage to fix it. :wink:


Thank you for letting us know, our team was working on it, and it must be solved now. If you are still experiencing the issue, try removing the Vera/eZLO Alexa skill and adding it again, please.

1:17pm CDT 24Oct2023, a Disable / Link process of the Vera skill in the Alexa app found the missing 38 Vera controlled devices. Thanks to those who reported and fixed the problem.
Best regards.

Still having problems after removing the skill and devices from Alexa and then re-adding. Alexa says they are there but then they are unresponsive.


For me it is all working again. One tip from my end. These type of issues are typically not caused by your local setup. So, do not start with adding and removing stuff right away. You will brake more than you fix. Report the issue and wait some time and 9 out of 10 times it will all work again. Other than reporting the issue I did nothing, and it all works like before.

Cheers Rene

1 Like

for me it is working with Ezlo. But I still see that if I create a virtual devices like a DIMMER SWITCH with an Alexa rule: Switch OFF or Dimmer to 0%, nothing happens.
Same with BULB RGB. Does it work to someone else?