Cannot add Qubino Flush shutter

I’ve tried at least 10 times today to pair one of my Qubino flush shutter ZMNHCD1 and keep getting every single time the following error: Z-Wave device 191 ERROR: Failed to setup security. Please

The device is plugged in less than 50cm from my VeraPlus so distance cannot be the problem…
I have a whole bunch of those devices working currently and while I sometime had similar issue during pairing, it usually worked within 2 or 3 attempts.

Any idea whar I could do to make it work?

It is funny I was just discussing this very problem with the firmware developer just a few minutes before your post but on another device requiring secure class inclusion… The vision/zooz/monoprice 4 in 1 sensor.

Not sure how this is going to help you but I can at least share what I discussed.
This problem is a function of how large your network is and I discovered that when I am on a brand new zwave network, it includes without any issue. When I had about 70 devices I started needing 2 or 3 attempts in order for the secure class keys to exchange properly. Now with 143 nodes, I have near 0% chance to get it to include securely.

My suspicion from the behavior and the logs I have seen is that as the network gets larger, the vera UI response lag increases to the point of missing the time window the device is allowing to exchange the security key causing the device to timeout and depending on the device, to fail inclusion or to fall back to non secure inclusion which confuses the vera which then fails the configuration process.

My workaround has been to use openzwave and it is a pretty advanced operation requiring extraction of the security key from the vera, installation of openzwave and inclusion from it using the vera security key. I have had this problem for years and reported it to CS which lead to my workaround. Hopefully the next FW fixes it.

1 Like

Hi guys,

We are already investigating this and it is work in progress. We’re trying to replicate it but it’s not easy - It would help the devs if you can tell me how many devices you have in your z-wave network and we’d also need a set of verbose logs with the inclusion process.


1 Like

I have about 50 devices…

I managed to solve the issue yesterday at least for this device.
The solution in my case was a combination of factory reset of the Qubino module and a reboot of the Vera right before adding the device. Either of those two alone didn’t help.

We’ll see in the near future if the same issue appears with the next device I’ll add

Just want to guide you to this thread:

Noticed that a reload or a full reboot is also being discussed. Back when I had about 70 devices, I also had significant success probability in secure class key exchange right after a reboot.
To configure the device, a key exchange is still required and I remember having to do a luup reload while the vera is waiting to exchange key and manually waking up the device. I will provice @edward with some more advanced logs. I have no problem reproducing this issue as I have 0% chance of secure inclusion from my vera these days.

I’m having another problem lately that is probably related…
I’ve added 6 Qubino flush shutter ZMNHCD1 in the last two month. Most of them had inclusion issues as described above, but at some point I always managed to get them in.
Now after working for several weeks, every few days another one of them (this morning was already the thirs one) is suddenly not being detected anymore by the controller and the only thing to do is to get them out of the wall and start the setup all over again. That is extremely annoying since they are included in a lot of scenes which takes quite some time to get back to the old state.

Anybody has ever had such issues? Is it maybe also related to the network size?

I have had this with my 4 in 1 sensors as well and have been learning about zwave since…
In my case, if one of these sensors go out of battery for too long (1 or 2 days maybe after a heal) the zwave internal heal will tag it as “is failed” and will stop looking for that device. If I then put fresh batteries in them, the sensors will work perfectly fine but the vera will still show it as cannot connect on the UI.
I discovered that if I restore to a time before I ran out of battery without restoring my zwave network, I still have the problem. I will see the device as fail every few minutes even though it is well within polling or wake up event schedules. If I restore with zwave network restore, the problem goes away.
Conclusion: The vera luup engine checks with the zwave chip registry on a regular basis and displays the devices which were tagged “is failed” by it and has no way to bring it back. I later verified this by moving my network to a USB dongle and can now plug the dongle into another controller and see the “is failed” tag. I can use that controller to remove that tag and plug it back on the vera and the problem is gone. Not sure what mechanism the vera would use to untag… maybe a device reconfiguration but because of the secure class key exchange on a large network being so painful, I have memories of spending hours trying to get one of these sensors to reconfigure, it was not a good option.

Now for you, it is likely that a nightly heal process had the zwave chip determine that your device was dead. It might be a bit out of reach or you might have interference at night during the heal? Try restoring from backup to see if the device comes back. When it is tagged, can you still actuate it?

Well the battery use case definitely not applies in my case since those devices are hard wired to power source…

The range could theoretically be although I have a whole bunch of other devices further away or in the same room that don’t have the issue. Moreover the once that had the problem were all located at completely different distances and in different rooms. So range is maybe a factor but definitely not the root cause

It’s quite odd that the 3 devices that have showed the problem all were added in the last month

Piling on here. I see the same issue with secure inclusion. A device will include on my test system which only has a few Z-Wave devices without a problem. My production system with over 150 Z-wave devices has , as @rafele77 points out, a very low probability of success.

1 Like

I just sent my verbose log of a failed secure inclusion attempt to @edward Let’s see what he can find out. Fixing this inclusion issue may not fix @mouch 's problem directly but should enable to recover with just a reconfigure and make inclusions easier.

A couple of suggestions for firmware changes I will post here:

  1. I would propose to create a new error message for having the device on the failed list instead of “can’t detect device” since it is confusing when the device still functions, reports status and can be actuated. Something like “tagged failed” would be great.
  2. I would suggest also an easier way to remove the device “is failed” tag from the dongle database automatically if it is reporting anything. I know there is an serial API command to do this. Right now it requires reconfiguring the device.

Today two more of the new devices got unresponsive (cannot connect) again although nothing change (hardwired so no battery issue)…
I’m getting tired of having to get them out of the in-wall socket to reset them every other week.
It takes several hour of work and I have to define all the scenes all over again.

I don’t have a alternative Hardware handy to remove the “is failed” flag. So is there a way to fix this from the Vera itself or maybe is there a beta firmware available with a potential fix?

We’re still working on this but we’re having difficulties as it’s replicating on very large setups (50+) devices and it’s hard for us to put this number of devices of the same frequency on a hub. The guys are hoping to see some positive results for these devices in 7.30 due to some other related fixes tho.

1 Like

Any chance to get our hands on a beta version? Or is there a timeline available?

Send me the beta… I have 144 zwave nodes on my system. You should really stress test your firmware with 200+ nodes and it’s hard for you guys to get any validation of your firmware without it. If you struggle to only put 50 on, it is no wonder you are not seeing most of the problems. How can you claim the number of device support on your marketing sheets without this?

1 Like

iam having the exact same problem with some quibino flush shutter, from time to time they get unresponsive
were you able to solve this problem?

What’s the problem?

I have two Qubino DC Flush Shutter modules and they pair OK with my Vera Plus every time no problems.

Howevwr these Qubino shutter modules have been a disaster for me as they don’t calibrate the roller blind upper and lower limits properly and they randomly just stop when they should not when moving the blind up or down.

have you tryed calibrating the modules using the parameter 71?

Think it’s parameter 78 on the DC module.

It’s meant to go fully up, down and then up again however it never completes.

You can also calibrate it instead with an external switch connected. This does seem to work OK.

However over some time it loses its calibration.

And even when it seems to be calibrated it sometimes randomly just stops when it should not when moving fully up or down.

You can also instead configure a timing for motor movement with parameter 74, I’ve tried this as well and it doesn’t help.

Either these Qubino shutter modules are junk or they have serious problems with Vera.

Also on the DC motors there are only two wires to reverse polarity for up / down etc.

If you wire them exactly as per the Qubino instructions, then it’s wrong in the Vera GUI.

In the Vera GUI 0% is closed and 100% is opened.

Yet if you wired it following the Qubino instructions then when the blind is actually closed it shows as opened in the Vera GUI.

And when the blind is actually opened it shows as closed in the Vera GUI.

To correct it I had to reverse and swap round the two wires from the Qubino module to the DC motor.

I wish I bought a 240V motor and another Fibaro Roller Shutter module now.

I’ve spoken to Qubino support via email and tried everything they have suggested with regards to various parameter settings and nothing has fixed it.

Also worth noting I have the older Qubino DC Flush Shutter modules. The firmware is denoted as S5 version.

On the latest modules the firmware is S7.

Now sometimes you can send your modules back to Qubino and request they update the firmware.

However I’ve been told they cannot update my modules as the hardware has changed as they have changed the flash memory chip.

Not sure if the new modules with the newer firmware would help with my particular issues though? Do I want to spend another £48 to find out? Or cut my losses with Qubino and DC motors.

My gut feeling is that this is a Vera integration problem as others seem to rate these modules highly with other Z-Wave controllers.

But that’s just my opinion not proven.

OK I’ve read this thread now. I have 40 to 50 Z-Wave devices and I’ve not had any issues at all pairing these modules.

Just issues with their daily operation as I described.