Can the veraplus be UNBRICKED?

I also have come into a bricked veraplus, you will notice that this one has headers soldered on the board (not done by me), maybe a returned device that was repaired and sold again?

Would like to take a stab at getting it running again. Does anyone know the recovery procedure? Are these pins for serial communications ? The leftmost appears to be ground and the other 3 pins are at 3.3V.

I don’t have an oscilloscope at hand, but might just hook it up to a raspberry pi if it is indeed serial.

Have you tried this yet?

Yes I tried that…I’ve gotten all other lights on and power light blinking slowly.

I’ve experienced this twice, and both times, the system was in OpenWRT failsafe mode and had an SSH server running, so I could log into it. From there I was able to determine that one of the mtd devices had been created but wasn’t completely formatted, causing the upgrade scripts to continuously loop, thinking the partition is ready for data when it isn’t, and subsequently timing out after a couple of minutes of waiting for it to come ready and rebooting, over and over.

If the lights are cycling briefly every few minutes, and when they stabilize to just the power light you are able to SSH into the box (but it later kicks you off), you may be experiencing exactly this, and it’s easy to fix. Let me know if you can get an SSH connection at any point (you may have to try several times over several minutes), and if you can, I’ll dig out my notes and send them to you. The fix is as easy as clearing the partition with one command, and then the thing fixes itself from there. There are actually a couple of versions of this problem and fix buried in forum threads here.

When power is applied to the box, the power light only comes on and stays on. If the reset button is pressed during power on, all the other lights are on and the power light blinks.

I see no network traffic on Wireshark and can’t reach the device on

Sounds like you’re on the LAN ports? Use the WAN port of the Vera into your network, let it get an address from DHCP. Find that address, and attempt SSH to that.

The vera plus only has one ethernet port so you can’t choose WAN or LAN, it is one and the same port. and no I have never been able to boot the vera plus in openWRT failsafe mode. It seems to me that at least my vera plus has no failsafe mode…

Rafale77, I would like to believe that the pins on the board can somehow be the path to recovering the device.

I am willing take the long road to get this going again, but you may be right in that there is no failsafe mode.

So it seems like these are uncharted waters but I’ve gained serial access to the machine. Posting a few screen captures to see if it jogs someone’s memory (no pun intended).

1 Like

Not jogging any memory, but the disc is not correctly initialised (or screwed)

I assume you get no command prompt. If it was a normal machine it’d be boot from external device and start again but…


Is this 4-pin header the console serial port?

Is this 4-pin header the console serial port?[/quote]

That is correct.

Thanks—good to know.

The last line… "Kernal panic:… Is the key…

During the boot process, the bootloader can NOT load the operating system due to a corrupt flash file system. This is causing a kernel panic. At that point, the processor is no longer operating. As there is no operating system loaded, and no network access to the unit, it is well and truly dead and unrecoverable. (Mios Customer Service has stated that a Vera Plus or Vera Secure needs to have network access for recovery to be possible)

Unless you have the equipment to do In-Circuit flash chip programming, you have an expensive doorstop.

Like I said… I am willing to take the long road with this.

Have you been able to identify a JTAG header? (since you’re taking the long view.) :slight_smile:

So I’ve come back to answer my question…yeah, maybe the veraplus can be unbricked.

Well done! Perhaps a write-up?

Respect to that!


[quote=“Catman”]Respect to that!

Wow! Respect!

I hope you can post how you have done it. I have a VeraPlus in the sane situation. It has only the green light. Support gave up on it.

Verstuurd vanaf mijn SM-T813 met Tapatalk

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules