Camera add as "undefined" and cannot delete through UI

The name and device type both end up being “undefined”. It wouldn’t let me delete them, it came back with some invalid plugin error, but I figured out how to delete them through port 3480.

I’m using the Manually Add link when adding a camera. I have a mixture of cameras, but I’m testing with the Sharx ones now (same thing as Y-cam). Other people seem to have it working by using /snapshot.jpg, but for some reason it’s creating the device wrong for me. Thoughts?

I’m running 1.5.432.

I have the same issue, how did you deinstall the cams?

The search function is your friend! Have a look here:,12252.0.html

  • Garrett

What causes the cameras to be added incorrectly? I have tried re-adding them and get the same behavior.

Sent from my Galaxy Nexus using Tapatalk 2

[quote=“garrettwp, post:3, topic:173157”]The search function is your friend! Have a look here:,12252.0.html

  • Garrett[/quote]

Cheers,that was easy

I have 4 Foscam Fi8910W with MCVFlorin’s plugin. Ever since I added the last 2, Vera randomly creates zWinTop camera devices with the same IP’s as the Foscams. I’m unsure what plug-in they are using but when I delete teh zwintop and it’s plugin it doesn’t affect the Foscam plugin and the 4 FI8910W cams hooked into that.

I notice when Vera does that as the zWinTop ones will show up on the camera list when I run Vera Remote.

All 4 cams are hooked into Vera’s WiFi. It’s not debilitating but it is kinda irritating. Any suggestions or ideas what may be causing this? It seems to happen after a power failure (being in Tampa Bay, brown-outs are a fact of life thanks to Tampa Sometimes Electric) Unfortunately I have no way of hooking them up to a UPS. :frowning:

The auto-detection mechanism in Vera will incorrectly detect a Foscam as a zWinTop camera if the Foscam is password protected (with your own username / password). (Prior topic.)

@OTI@: Thank you. I had searched but must have missed that one. The weird thing is that the zwintop dupes only happen for the last 2 added Foscams. The first duo has no problems. All are FI8910W’s. The only difference is that 1 and 2 are white and 3 and 4 are black. I’m sure I set them all up identical, but I’ll go over the settings again with a fine toothcomb.

Has anyone else had the problem of manually adding an unsupported camera and having it show up as undefined?

Sent from my Galaxy Nexus using Tapatalk 2

Did you check that the firmware versions are the same in the black and the white cameras?

The 2 that don’t cause zWintop dupes are both
Device Firmware Version
Device Embeded Web UI Version

Of the 2 that cause the zWintop dupes one is the same as above, the other is
Device Firmware Version
Device Embeded Web UI Version

I did notice something scouring over the settings. The first 2 had a MAC address that did not tally with the Device ID. I remember hooking them up to Vera wired first to config the wireless. So the MAC that’s in there is the one for the wired jack most likely. The last 2, I hooked wired to my normal LAN. Those do have the correct MAC address listed. I corrected the MAC address on the first 2 to match the Device ID on the camera status page. Lets see if now I get 4 zWinTop dupes instead of 2.