[BUG] v5.5 - Notifications being sent when PLEG in Bypass

I just created a new PLEG strictly for when the home is in Vacation Mode.

It is in Bypass currently

While in Bypass…
It is not running the Actions
It is sending notifications - I’m receiving them in Vera Alerts.

I hope this can be fixed as these notifications are only wanted when there is a ‘security breach’ and the PLEG is Armed.

You could replace the notification with VeraAlerts>>SendAlert using the Advanced tab in the action editor.

I don’t think that will stop PLEG from sending a notification in Bypass… even if it does it is a work around, not a fix.

I posted this so Richard would know about the bug and hopefully fix it.

Okay. I think Richard is currently out of pocket

That’s not a bug … that is the behavior.
There is a second option in Notifications:
“A condition is is satisfied with specified status”

That allows you to also specify if PLEG is armed or bypassed as well.
However there are some MCV bugs (I provided MCV two patches during the early UI5 development … they installed one, but not the other, so I am not sure if this works. I have a patch but since it modifies a MCV file, I am hesitant to hand it out).

Bypass Only stops the actions from being fired … Does not stop the evaluation of conditions.

I’m just seeing your reply now, sorry for being late.

It is confusing - or more like, difficult to understand what that notification option means.

Either way… it seems that if someone puts a Device into ‘Bypass’ it should be bypassed… The setting is not called ‘Ignore only Part of this Device’ :wink:

I don’t see any use case where you’d want to bypass the Actions but still get notifications - except in testing. In this case, maybe there should be 3 options for PLEG Devices… Arm/Bypass/Test or better yet, Enable/Disable/Test

As a workaround, I removed the Notifications from that PLEG and will do it a different way.