Bricked Ezlo Plus hub ? Not connecting


One of my two Ezlo Plus hubs seems to be bricked?

Its a spare test hub and I don’t use it so often and I had accidentally unplugged its ethernet cable while messing around with my router to try and fix a different problem. So its been offline for several weeks / months.

Today I plugged the Ezlo Plus hub back in to the network, it then looked like it was doing a firmware update, looking at the lights on the front of it flashing and at one point I was able to briefly ping it OK, however ping stopped working.

I then pulled the power and back in again and now I have a solid yellow light and I cannot ping the hub and its offline,

Solid yellow means –

4 System has booted but firmware not FFFF00

Hello @cw-kid!

Have you tried to connect that controller directly to a PC/Laptop and ping the unit to check if there’s a reply from the host?

Is the unit responding to any factory/network reset?

No I have tried either of those things yet. Guess I will have to press the factory reset button thing.


Keep us updated in case there’s no result on the reset button!

1 Like

Which type of factory reset ?

Soft or Factory ?

One long (5 – 10 seconds) press|Soft reset

One long (10 – 20 seconds) press|Factory reset


The soft reset should be enough to reset network settings on the hub without getting rid of all its settings. You’ll notice the LED blinking white once per second (slow). If this doesn’t help, try the factory reset, and it should blink white twice per second (fast).

1 Like

OK many thanks I will try that later and report back to you.

Might be tomorrow however when I try it.

1 Like

Not a problem! Feel free to tag me as soon as you have an update.

I tried holding the reset button down for 10 secs which should be a soft reset.

The light on the front went red then changed from blue and green but then it goes back to yellow.

Then it repeats goes to red for a while then changes from blue and green and back to yellow.

And I cannot ping it either.

I then tried holding the reset button down for 20 secs for a factory reset. Its now just flashing red which means booting recovery partition acording to your pdf for light patterns.

So not sure what to do next as its been like that for se time.

Just pulled the power and back in again. Its currently flashing green and blue again, but then goes to solid red for a while now its solid light blue. That means its up I think.

I cloud then briefly connect to this hub in the Vera mobile app.

However then it disconnected and the light on the hub was completely off.

Now its back on and flashing green and blue so maybe its trying to update the firmware.

Now the light is yellow and now flashing orange.

Now solid light blue again.

Vera mobile app now connects OK.

IP address of the Ezlo hub is still the same as before as is its friendly name.

So think its working again.

1 Like

Glad to know! Restoring a backup should bring back any controller info that you had prior to the factory reset.

Please let me know in case further help is required. Feel free to tag me or reach out to me directly if that’s the case.

Says I have no backups for this particular controller.

I think I only had a few virtual devices on this particular Ezlo Plus hub so not the end of the world.

I have another second Ezlo Plus hub and that one is my main live hub. That does have backups showing OK in the web UI.

Thanks for sharing that info. Will remain attentive to any further help required.

This controller has gone down again. Its always says OFFLINE in the apps and I cannot currently ping it. I tried unplugging the power and back in again but its the same.

Could you please let me know an approximate hour from when it went offline?

I have no idea sorry when it went offline.

I just tried to reset it again now.

But it keeps going to a solid yellow light again.

Edit actually looking at it now its flashing green and blue again, then goes to red and then flashing green and blue. Then back to yellow.

Thank you @cw-kid. Was the last reset performed a factory reset?

I have reached out to you directly via support ticket since this might require further investigation! Looking forward to hearing from you.

Im not sure about last time.

But now the light is solid yellow. Holding in the reset button for 10 seconds or even more than 20 seconds, doesnt seem to do anything the light just remained solid yellow.