Blog post about Ezlo VOI™

Having linked VOI™ to my Amazon™ Alexa™ account, I’m kinda lost at this point. The VOI info page:

… says “a virtual device will be created”, but I see nothing, neither on the ezlo VOI tab:

… (where pressing [+] just takes you around again…

… to the “Linked” confirmation dialogue) nor under “Devices”:

Remind me again where to find the Virtual Device we use to send VOI commands?

Hi @LibraSun,

I get the exact same thing trying Alexa with the Linux Edge. It just goes in circles. Never works.

Ok after typing this, thought lets look again with the latest beta Vera Android app. I now see a whole series of Alexa devices. Not good either. See if I can get that back to 1 and working.

Cheers Rene

I’m still stuck on app beta .360 (been waiting a couple of days for .369+ to push to my phone, no luck yet), so maybe that’s my hangup?

From your Reply, I gather it will eventually show up as a Virtual “Amazon Alexa” Device under “Devices” as the verbiage cited above suggests, and as the VOI “Getting Started” Guide indicates.

Can’t wait to try! :smiley:

  • Libra

Well. I am still getting no where. I cannot find a way to delete the Alexa devices. And because the scene editor for the normal Veras in completely broke in this version I will not reinstall it for now. I also do not expect they are stored in the app storage on the phone. However, in the Linux API they do not show as devices to delete either.

So, still not working. Maybe I need to reset the controller and start again. Well, no point in a reset. All devices gone except those pesky Alexa ones.

For the Beta make sure you are still registered as such with Google. maybe redo the steps for getting the beta.

Cheers Rene

1 Like

I might try some of those steps, although I’m pretty sure the “Vera Dashboard” Google Group was essentially abandoned the day after its inception?? (So far as I know, there’s no other place – besides Google Play Store – for me to ascertain whether I’m still “in” the beta, as joining the Group was the only requirement.)

Hi @LibraSun

Delete is not working because of the beta version. We are working on it. That will be released soon. I will inform you.

Cheers ilkan


@ilkan, could someone please post a video of a Linux-firmware Vera Edge actually using VOI? I kinda feel like I’m being punked here, staring at blank screens in the .369 app where “Amazon Alexa” should be.

I’ll also take any and all suggestions to try – thought that was the purpose of our “Vera Dashboard” Google Group, but evidently it’s not being used for communication?? – since I got the Edge and flashed it just for this purpose!


  • Libra


On a positive note. With the .360 beta Google Home started working.

Cheers Rene


Hi @LibraSun, we’ve done a fresh setup - just upgraded a Vera Edge controller to the Ezlo Linux firmware and we’re able to use Ezlo VOI™ commands, here is a short video:
Vera Edge running Ezlo Linux firmware - Ezlo VOI™

I talked with our team and answers are provided now in the group, lately it was not on the radar. Thank you for bringing it up.


1 Like

Thanks (I watched it), but… seems that, no matter how many times I repeat the App > VOI > [+] > “Amazon Alexa” > “Allow VoiEzloProfile” > “Linked!” > [Done] process, I get absolutely no “Alexa” device as your video depicts.

So, is that just me? Just .369? Other users as well?

CORRECTION: Somehow, I’m back on .360 of the app?!? Will keep waiting for .369 to roll around again.

NOTE: I even see “Libra’s Ezlo VOI” listed among registered devices in the Alexa App > Settings > Device Settings list … except it shows “Device offline. Some setting may not be available.”

NOTE, TOO: I even removed/unregistered the “VOI” entry in that Alexa devices list, then logged out of the Vera spp, and started everything from scratch. No dice. Like I said, waiting for .369 to install itself. C’mon, Google!

Stumped. - Libra

Hi @LibraSun,

For me the beta also shows .360. It was available since March 13. I have not seen a .369 version. I expect they are spending a bit more time testing the next Beta as the .360 should never have been made availble as Beta.Too many Vera functions broken.

Cheers Rene

Yeah it was definitely not ready for external testing, that said I don’t mind as my Edge was bought just for experimentation.

Well, my big problem is that the app is mostly broke for Vera’s even the current production version of the app. There was too much focus on the new forgetting to regression test the existing (what 99% uses).

Maybe I was dreaming? Perhaps my fancy footsteps of deleting/reinstalling the beta app to force-push .369 over the weekend just nabbed me .360 all along?

Times here in New Orleans are stressful, so that’s entirely possible/probable.

I just know I won’t be doing much testing with .360 or any other version until someone else says the coast is clear for simple things like listing Devices and Scene editing (i.e. it’s no fun to beta test alpha ware!).


From build 7.40.360 we made two new releases on the beta that gathered the fixes made by us based on customer care tickets and community raised issues. The latest is 7.40.371.
Due to the current circumstances with COVID-19, Google warns us that they will have a delay in reviewing the apps to a week or even longer.

This delay is also confirm in the Play console’s Help documentation.

We are sorry about any inconvenience this may have caused. We are doing the best we can.
Thank you for your feedback and reviews.


Who ever imagined software would be affected by an actual virus??

1 Like

Hehe, I must say I’m glad I work for a software company as our entire org has been able to WFH without issues.


Answer: Because otherwise the Spot is the only light source in a bedroom we prefer porch black while sleeping.

1 Like

Short answer: Nope.

Long answer: I tried every variation of command asking the master bedroom echo spot to turn off its screen, with no success.

Oh, well. That’s an Alexa problem, not yours.

At seemingly random times, I get an error message popping up saying “Locations were not found”.

NOTE: “phone to silent” is an IFTTT recipe I routinely use in this fashion through Alexa.

UPDATE: Success! By trying this same command from a different Alexa device (specifically, the last one in the VOI list), it worked!! See screenshot below: