Blog post about Ezlo VOI™

At seemingly random times, I get an error message popping up saying “Locations were not found”.

NOTE: “phone to silent” is an IFTTT recipe I routinely use in this fashion through Alexa.

UPDATE: Success! By trying this same command from a different Alexa device (specifically, the last one in the VOI list), it worked!! See screenshot below:

You are right. Alexa doesn’t support that.

Assume that, you have alexa physical devices A and B. When you send a command to use your alexa device B’s capabilities from your device A it might not work because of alexa.

For example when you send command to your device A “tell me the weather of new york” it works. But when you send command to your device A “tell me the weather of new york from my device B”. It does not work. In alexa many of the alexa device related commands works for only in that device.

Thus, please think about VOI as a virtual device that you can reach it from Vera app.


Ah, so my week long experiment was doomed from the outset. I see.

Meanwhile, I’ve been able to successfully play music and such at whichever Alexa I indicate, as here:

In your IFTTT case is also the alexa problem not VOI. As I said voi is the virtual represetation of the alexa. If physical alexa can do something, voi can do. When you see “voi controller is not reachable” like response from vera app there might be a problem on VOI.


Play music is the exceptional case. You can do it between your alexa devices.

Ok, I see. Let us check that case it with Alexa team. As you know, VOI is still in beta. Some of the capabilities are limited.



1 Like

NEW FEEDBACK: Field entry challenge

Whenever attempting to edit existing “Command” in VOI, the cursor jumps to the end of the field during typing, no matter where it was initially placed within the string.
See attached screenshot for example:

In this instance, I had placed the cursor at the beginning of the string and began typing “alexa”… which got turned into gibberish. 100% repeatable.

Hmm…we fixed this issue in the past.
@LibraSun can you please provide us with the Android phone model you’re using?
As for the VeraMobile build please confirm you use the latest version from Firebase v.7.40.376.

Thank you

We have checked, but couldn’t reproduce your case. I’ve tried this IFTTT aplet more than 10 times that works every time. It seems there is an applet issue on IFTTT side. If you give me your applet, I can also try yours.

VOI command from vera app phone is not muted:

After VOI command, phone is muted



1 Like

I can confirm this is all in the latest beta thru Firebase, .376, installed on a rooted One Plus One running Lineage OS nightly (Android 9).

NEW FEEDBACK: Confusing language

I think the verbiage on this legend under “Scenes” may tend to confuse users, in that it claims “Scene is always active”. Not sure what it’s supposed to mean.

Likewise, “unless you have specified it a specific” is awkward phraseology; it should be rewritten entirely and then proofread.

NEW FEEDBACK: Cannot save (new) Scene

For whatever reason, after getting all the way through setting up a new Scene in beta .376 (connected to my Linux-based Vera Edge), I received this “Failed to save scene!” error message and the Scene refused to SAVE:

(a) “mode Away mode” is redundant;
(b) Assignment to “No Room” was intentional on my part (as I had not yet defined any rooms);
(c) The triggering condition was of the “AND” variety, with two time-related triggers assigned (let me know if you want those particulars).

NEW FEEDBACK: Spoken acknowledgments (TTS)

Beta revision .383 of the app audibly says “Okay” after successfully issuing a VOI command. This is neither expected nor welcome. If this change in behavior is intentional on your part, then I’d like a way to turn this feature OFF completely.

@Ioana, I can further confirm that the earlier-reported issue CONTINUES TO HAPPEN, of the VOI Command field constantly moving the cursor to the end while editing. This makes changing “on” to “off”, for example, nearly impossible and a real chore.

No improvement on this for 2 beta versions now, up to and including .383.

1 Like


With LibraSun here. That latest .383 beta is still not working for Scenes with a Linux Edge. You can enter and test the command. But if you click Done it still says command cannot be empty (it is not!), and if you skip test it proceeds, but does not store a command. The logic is the exact opposite from what is on the screen. That says you must click Test or you cannot proceed. Now you cannot proceed when clicking Test.

Please do a bit better QA before asking users to test.


Will Ezlo VOI be released in the next firmware update for the VeraSecure?

1 Like