Beta - VeraMobile for Android v.7.69.2.1

We’re releasing today a new Beta update for VeraMobile for Android v. 7.69.2.1 with the following:

New features for Ezlo controllers:

  • Add support for adding a virtual device
  • Add support for changing a virtual device capabilities
  • Add support for deleting a virtual device
  • Add support to send commands from a virtual device and display controls
  • Add support to use virtual devices in scenes

Fixed issues:

  • Devices list flicker on dashboard sometimes after login and on device changes status
  • Done button from HTTP request /Authentification Request doesn’t stay on top over keyboard if the app is opened from the background
  • Controller disconnected from power don’t report online status
  • Sometimes the app crashes when the user taps the back button to return to the recorded tab after he plays a video record
  • Edit trigger event displayed in creating a scene is the one present instead of the one selected by the user
  • Edit trigger event displayed in edit scene is the one present instead of the one selected by the user
  • User is disconnected from the app when the app is opened from standby mode.

For those of you that are Beta testers via the Google platform and want to test the build faster, you can enroll at this link , as we’ve changed the tool to distribute the builds - if you haven’t done it already. If you already use the new tool, you’ll receive an app update with v.7.69.1.47.

1 Like

The device tiles flickering on the Dashboard Pro finally appears to be solved good job!

1 Like

Just tried to add a Google Home virtual device an eWeLink essential oils Bamboo Diffuser.

However it says this when trying to turn the device on.

“Temporary Unresolvable Request”

If I directly ask a Google Home speaker to turn on this same device that works OK.

Also this device has an RGB light on it can you add support for RGBW lights?

The virtual device also looks different in appearance than a regular Vera device.

However its a nice concept for sure and could be very useful in the future for controlling devices that Alexa and Google Home support but that Ezlo don’t support themselves directly.





What does this mean?

For example could we add a virtual device that’s not linked to either Alexa or Google Home, say a simple ON / OFF switch and then be able to send a HTTP request out for when the ON button is pressed and a different HTTP command sent out for when the OFF button is pressed.

Now that would be very useful. Currently to do this on a Vera hub you either have to use a 3rd party plugin of some kind for virtual switches or you can do what I’ve always done and manually create your own virtual switches and then use PLEG to send out a http request when the virtual switch is operated.

I’m currently using Multi System Reactor logic engine now rather than PLEG however, to monitor virtual switches and it sends out the http requests, so same concept.

Want an example why you might want to do this?

I have a virtual switch that turns on or off the motion detection function of my Hikvision IP camera. A http request is needed to be sent to the Hikvision API on the camera etc.

Also there are many other reasons for wanting this functionality and I have lots of virtual switches that send http requests out to various other devices on my LAN.

1 Like

Hello @cw-kid

We’re going to recreate that scenario and get back to you with some ideas.

1 Like

VOI isn’t currently working for me chatting to Google Home.

Says “VOI Controller Unreachable” which is likely why the virtual switch above isn’t working either.

Hello @cw-kid

That issue has been reported already and you can follow the progress in this link https://jira.mios.com/browse/ECS-9

That url just goes to the landing page of the Jira system.

Hello @cw-kid

Try to login with the account you created for JIRA and search for the ticket ECS-9

URL works on my laptop was on my phone earlier.

This is the full URL

https://jira.mios.com/servicedesk/customer/portal/72/ECS-9

Looks to be an existing ticket about not being able to link Google Home, which has nothing to do with me here and what I have said.

In that case, we recommend creating a new report and if possible, please attach screenshots and/or videos of the error. Also, we’ll run some test and try to replicate the issue.

New ticket then

https://jira.mios.com/servicedesk/customer/portal/72/ECS-554

1 Like

Thanks for the update!

Think there is a bug here. I tried to rename my virtual device from: Bamboo Diffuser (Virtual) to: Bamboo Diffuser (Google) clicked the save button, however the device is somehow then named “Google Home”.


I then tried to name the virtual device: Bamboo Diffuser (GH) instead and that worked OK.


Ezlo VOI is still not working for Google Home. However VOI is currently working for Alexa.

So I created a brand new virtual device named: Bamboo Diffuser (Alexa) similar bug, the device ended up named as: Amazon Alexa instead.

Anyway this virtual device is working I can turn On and Off the device via the Vera app etc.

I then renamed the device instead to: Bamboo Diffuser (Echo) which worked OK.

Well the new Alexa based virtual device only worked one time. Now when I press the On / Off buttons it says:

"Temporary Unresolvable Request”

I can still chat with Alexa OK however via the Ezlo VOI text command input.

I have a WiFi LED controller from Magic Home which I’m not currently using. However its linked to Google Home / Assistant.

I added a new virtual device for Google Home and this Magic Home LED controller.

Same deal with this cloud based device also, says:

"Temporary Unresolvable Request”

When pressing the On button on the virtual device in the Vera mobile app.

I haven’t linked this device to Alexa as yet.

EDIT:

I’ve now added and linked the Magic Home skill in the Alexa app.

I then created a new virtual device based on Alexa for this Magic Home LED controller.

I am seeing different behavior, when clicking the On button on the virtual device in the Vera app, it says “Command Sent”.

However then looking in the Magic Home app the light is Off not On, so it doesn’t appear to have worked and turned on the light / LED controller.

EDIT 2:

EZLO VOI for Alexa chat works I can type the command and it does turn on the Magic Home LEDs OK.

The LED controller device does then change to ON in the actual Magic Home app.

Hi @cw-kid

Thank you for your thorough feedback. Please make sure you to send it the right way by reporting it using the bug tracker as suggested by Sara. That’s the best way to have those reports reach the developers :wink:

Ticket was already logged pointing back to this forum thread, they only have to read downwards.

Hi,

What I found is that the virtual ‘device’ only can do VOI commands and only exists in the App. I.e. there is no device on your hub for it. This means it will not be usable for any code running on your hub.

Cheers Rene

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules