Beta - Ezlo Linux v.2.0.9.1382.15 hot fix for Ezlo Plus controllers

We’ve released a hot fix for Ezlo Linux v.2.0.9.1382.15 for Ezlo Plus controllers:
Hot fix:

  • Fixed the issue on Ezlo Plus with losing all devices after the firmware upgrade. This new Firmware version will restore deleted devices but not also scenes, rooms, favourites. These will need to be recreated.

Known issues:

  • Issue with the Led behaviour in the devices exclusion process where the LED on the controller flashes as if the controller is still in exclusion mode even after clicking the “Exit” button to exit from DPW.

  • Issue with sensors that can have the status changed to Armed after the upgrade in case there are zwave plugin changes for those specific devices from one FW version to another.

  • Issue on devices that support Tamper where the broadcasts and notifications generated are opposite to the actual tamper state

  • Issue on Z-Wave devices with “electric_meter_amper” that is updated only when the hub is restarted. Ampere meter not changing value instantly once pairing a device supporting it (for example pairing a switch and adding some load to it - e.g. connect a bulb)

  • Issue with incorrect sunrise/sunset time for scene in case the timezone is changed after enrollment. The sunrise/sunset scenes are calculated based on location and for the moment we do not have UI support to change it after enrollment (API is in progress of being integrated in UI)

  • Issue on Vera Edge where after the first update from Vera FW to the new Linux FW the “Internet” LED is OFF

  • Issues with some Door Locks, as Danalock V3, that are not added with S2 encryption

  • Vera Edge Wifi connectifity issues:

    • Issues the Vera Edge controller not being able sometimes to connect to a Wifi network
    • Issus with disabling wifi interfaces not working on Vera Edge
    • Issues with hub.network.get method reporting AP interface as up, even if it is disabled
2 Likes

Can confirm, all the devices are back. Thank you!
Too bad they all got new names, device and items id though.

1 Like

I would be curious to know how many units are being tested in-house first, and whether they are different from beta units in the field, such that the previous f/w release (.14) was even able to pass QA testing and get pushed?

1 Like

QA issue for .14 was something to do with a “build server”…
As we are expanding new build servers are being added.
for 450 range, the team added a new build server. One of these servers, due to human error, was not integrated into the QA process. 550 build servers were integrated to QA for example, thats why we only had this issue for .14 for 450s…

Problems, in the main, are not “when repeating” tasks, but when “setting them up new”.
Needless to say we continuously learn from our mistakes.

Hi @melih
What is the 450 please?
the beta test EzloPlus is different from the marketed EzloPlus ?

1 Like

All devices seem to be back, but all names are reset and all are located to No Room. So I have no chance to know what device it is. I think I have to re-include each device nevertheless…

1 Like

I had to physically toggle them one by one to figure it out. Added them back to existing scenes and assigned to correct rooms.
3 out of 19 devices did not respond at all and had to be re-included.
Updated all my external scripts and virtual devices on Vera to the new ids, all back for me now.

2 Likes

I think, I’ll wait untill some of my devices will work as it should. None of my devices added to Ezlo Plus is working right:

  • Multisensor 6 is missing the motion sensor and none of the other sensors shows any value (incl. battery)
  • Eurotronic Spirit Thermostat doesn’t show anything
  • Fibaro Smoke Sensors don’t show temperature and battery
  • Heiman Smoke Sensors don’t show battery

I don’t see any progress in this regard. But on the contrary. Devices that worked fine in the beginning (Eurotronics Thermotats) are no longer usable. Am I the only one with these devices having trouble? Should I consider completely resetting the Plus and starting over, or wouldn’t that help?

Hi,

seems I was just too impatient… rooms are now available. Not tried creating one.
Also able to change the device names etc. Phew!

Thanks
Tony

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules