Beta - Ezlo Linux v. for Ezlo Plus, Ezlo Secure, Vera Edge controllers

We’ve released a new Beta update for Ezlo Linux firmware v. for Ezlo Plus and Ezlo Secure controllers and Vera Edge running Ezlo Linux fw with the following:

New Features:


  • Bug fixing and improvement on the Wifi connectivity
  • Fixed the issues with Controller not being able to connect to a hidden WiFi network

Known issues:

  • Issue on devices that support Tamper where the broadcasts and notifications generated are opposite to the actual tamper state

  • Issue on Z-Wave devices with “electric_meter_amper” that is updated only when the hub is restarted. Ampere meter not changing value instantly once pairing a device supporting it (for example pairing a switch and adding some load to it - e.g. connect a bulb)

  • Issue on Vera Edge where after the first update from Vera FW to the new Linux FW the “Internet” LED is OFF

  • Issues with some Door Locks, as Danalock V3, that are not added with S2 encryption

  • Vera Edge Wifi connectifity issues:

    • Issues the Vera Edge controller not being able sometimes to connect to a Wifi network
    • Issus with disabling wifi interfaces not working on Vera Edge
    • Issues with method reporting AP interface as up, even if it is disabled

With this build E450/E550 hubs creating backups automatically every 24 hours.
Backup has information about all included Z-Wave/ZigBee devices, scenes, etc.


Hi @Oleh,

My unit seems to make an online backup every hour since the update? Also how many backups are kept online?

Cheers Rene

this is good but I do not see where it is on the Android application? I still do not have access to Ezlogic with my credentials…

I wish I had this version a few days ago and backed up the Ezlo. Now I have to re-include all devices because I tried the “Reboot” button at witch completely wiped my device.


Unit is making backups each 24 hours only.
If by some reasom creation of backup failed, hub will try to do it after some period of time.
Let’s check your case, I send a message to you.

5 backups

Can that be increased ?

My Vera Plus is currently showing 15 backups available from the Vera cloud.

I’ve just checked my Ezlo Plus hub’s backups via the web GUI.

It now says: No backups yet…

There were some backups listed there previously however.

I have hard refreshed the web browser and checked again but it’s still the same.

I then checked the hubs current firmware version and it has updated itself to version


Whilst already in the Backups area, I just pressed the Backups button again from the menu on the left hand side and now I have a spinning wheel of death. I have seen this happen before also.


Ctrl + F5 again to refresh and then gone back in to the Backups area and now it says No backups yet… again.

EDIT 2: Just tried creating a manual backup by pressing the button and I am getting “Sorry, that didn’t go through”.

This issue did appear to be fixed a few days ago, as then I was able to create several manual backups OK. But now the problem seems to be back again.

According to the response of hub.backups.list there is a backup created every hour and it retains 10. So something does not align to the provided specs.

The ha-backup.log file remains empty now. Before I did see entries in it. (log level DEBUG)

1 Like

This is what I see in mine:

2021-05-07 13:47:34.115818 INFO : Prepare for creating backup
2021-05-07 13:47:35.880677 INFO : Start creating backup
2021-05-07 13:47:35.906833 WARN : Addon addon.2gig is not available
2021-05-07 13:47:35.907749 WARN : Addon addon.cloud_devices is not available
2021-05-07 13:47:43.549843 ERROR: Firmware service ui_service restarted during creating backup
2021-05-07 13:49:08.316909 INFO : Prepare for creating backup
2021-05-07 13:49:09.984875 INFO : Start creating backup
2021-05-07 13:49:10.010533 WARN : Addon addon.2gig is not available
2021-05-07 13:49:10.011444 WARN : Addon addon.cloud_devices is not available
2021-05-07 13:49:17.391856 ERROR: Firmware service ui_service restarted during creating backup

ERROR: Firmware service ui_service restarted during creating backup

And in the ha-restart.log, same time when I was trying to create a manual backup

**** uid Restarted at Fri May  7 13:47:43 BST 2021
**** uid Restarted at Fri May  7 13:49:17 BST 2021

However this log ha-cord.log says the backups were successful but I cannot see them in the web GUI listed:

2021-05-07 13:47:34.126807 INFO : Locking for a backup
2021-05-07 13:47:35.903520 INFO : Starting backup
2021-05-07 13:47:36.314414 INFO : Backup successful
2021-05-07 13:48:09.457792 INFO : Unlocking from a backup
2021-05-07 13:49:08.322412 INFO : Locking for a backup
2021-05-07 13:49:10.007401 INFO : Starting backup
2021-05-07 13:49:10.425196 INFO : Backup successful
2021-05-07 13:49:43.422203 INFO : Unlocking from a backup

Same thing also in this one ha-hardware_manager.log

2021-05-07 13:47:34.126114 INFO : Locking for a backup
2021-05-07 13:47:35.912263 INFO : Starting backup
2021-05-07 13:47:35.954584 INFO : Backup successful
2021-05-07 13:48:09.456832 INFO : Unlocking from a backup
2021-05-07 13:49:08.322004 INFO : Locking for a backup
2021-05-07 13:49:10.015894 INFO : Starting backup
2021-05-07 13:49:10.041559 INFO : Backup successful
2021-05-07 13:49:43.423820 INFO : Unlocking from a backup

Are the backup files also stored locally on the hub somewhere? As well as the cloud?

That’s not in the online API tool ?


Its a custom call:

(Ezlo can you add these new backup API calls in to the menu on the Online API Tool ?)

"method": "hub.backups.list",
"id": "_ID_",
"params": {}

It does show some backup entries in the response and I have 10 of them as well.


I’ve checked the time stamps off all these backups and I can also confirm that they are every hour.

Also none of the backups listed in the API response have a time stamp at the same time as when I was trying to create a manual backup. So they don’t exist it seems, even though some of the logs suggest they were successful.

I’ve just tried to create another manual backup right now to double check things and it does not create a new entry in my list of backups in the API Tool.

And as for the logs:

2021-05-07 14:30:16.483761 INFO : Prepare for creating backup
2021-05-07 14:30:18.488471 INFO : Start creating backup
2021-05-07 14:30:18.513336 WARN : Addon addon.2gig is not available
2021-05-07 14:30:18.514309 WARN : Addon addon.cloud_devices is not available
2021-05-07 14:30:26.341803 ERROR: Firmware service ui_service restarted during creating backup

Its still reporting as Successful when it doesn’t appear to be:

2021-05-07 14:30:16.489433 INFO : Locking for a backup
2021-05-07 14:30:18.522248 INFO : Starting backup
2021-05-07 14:30:19.078601 INFO : Backup successful
2021-05-07 14:30:52.120239 INFO : Unlocking from a backup

@reneboer Do you have backups listed in the new web GUI ? I do not.

How do you specify this?

Hi @cw-kid,

I still cannot access the web GUI.

Log level can be set via the API tool Logging - Ezlo API Documentation

I see some odd things with the logging now. Not all seem to be working anymore, nothing in the log files. The ha-zwaved.log is always logging as is the level is DEBUG, no matter what log level I set.

Cheers Rene

@cw-kid, @reneboer

Guys, in your case hub is sending logs to the cloud every hour.
Since this release hub is checking automatically every hour for rotated logs.
If it was found - sending to the cloud.

Policy for sending logs to cloud:

  • off - don’t send any logs till it will be requested
  • each_rotation - sends logs each rotation (each 24 hours or when logs become more that 1 MB).
  • store_locally - storing logs in the hub.
    Default value: each_rotation
    For switch it you can use request hub.setting.value.set

Here is the example of the request:

    "method": "hub.setting.value.set",
    "id": "_ID_",
    "params": {
        "name": "logs.send_mode",
        "value": "off"

I don’t get it?

The logs should always be stored locally on the hub. If in addition you want to send copies to cloud and no personal private information is given then fine do it.

But what does this have to do with hourly time stamps that we have seen on backup entries listed in the API?

@reneboer do you get what he’s saying?


Any update on the other two issues reported here today?

  1. Manual backups no longer appear to be working.

  2. No previous backups are now listed and shown in UI1 web GUI.


Hi @Oleh,

It are the backups being sent to the cloud every hour. With only ten backups listed by hub.backups.list, this only gives a ten hour window to recover a broken hub. Way too short a window.

The side effect seems that log are sent very frequently too.

I would think you can see on your cloud server how often these are send.

Another odd thing. The timestamp in the backups list gives a time 17 minutes past each hour exact. However, in the one line I can see in the ha-backupd.log and ha-cored.log the timestamps are 1 minute past the hour.

I will turn off log file uploading and see if I can see past one hour of events.

Cheers Rene

My backup time stamps in the API were the same also, 17 minutes past each hour.

I turned this off a few days ago. Now looking at the listed backups in the Online Api Tool, I am seeing these latest time stamps:

Mon May 10 2021 19:35:10 GMT+0000	
Sun May 09 2021 19:35:00 GMT+0000
Sat May 08 2021 19:35:03 GMT+0000

So it appears to now be only backing up once every 24 hours instead of every 1 hour.

However I am still confused. So what does this mean for every other user?

They aren’t all going to read this thread and run the API command to turn off “logs.send_mode”.

And I still don’t understand the relationship in the first place between uploading logs and backups ?


I can now see two backups listed in the web GUI, previously this was empty.


Time is wrong somewhere ! API backups list says 19:35 but in the web GUI is says 3:35

Time is also still wrong on the web GUI’s info panel, the time now is 15:38pm not 10:38am



This is still very hit or miss. I’ve refreshed the browser gone back in to Backups area and now they have vanished.


Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules